Windows wont recognize Cruzer Micro

plugged my drive into my pc today, its windows 7 64 bit. The noise saying it “sees” my drive is heard, but the only thing that shows up in my computer is the portion of my drive with u3 on it. Running u3 does nothing. It shows my cruzer in device manager, but not disk management and there shouldn’t be anything wrong with my drive lettering(the “partition” i guess, that shows up is G: and I dont have anything with F, or anything near G so that won’t effect anything. That is assuming this means the part with my data should be F). All my drivers are up to date. The drive does work on all my other computers. Help?

If you search the forums here you should find a thread for updating your U3 to Windows 7.  The update should be run on a Windows XP machine.  But I don’t think it supports 64bit Win 7.

Be sure you backup your data before doing the upgrade.

Another possibility would be to;

Remove U3.  It’s an option on the U3 menu.

Install the new SanDisk SecureAccess app.

Install’s suite of apps. 

I am not using U3 and I don’t want to.  Windows 7 won’t recognize my cruzer micro (16gb).  It will recognize the drive if I boot with the drive installed, but this seriously reduces the usefulness of the drive.  How can I fix this?

“It will recognize the drive if I boot with the drive installed”

What exactly does this mean??  You’re booting the USB drive?

I have the same problem …

Running Windows 7 64bit home premium … the Cruzer Micro is only recognized if the PC is rebooted with the cruzer plugged into one of the USB slots.  If you remove it and try and plug it back in then it is not recognized again until you reboot with it plugged in.

I see many people have similar issues with Cruzer and Windows 7 64bit … i haven’t found any answers yet?

Have you seen this posting??

Thanks for reply Ed …

I have tried it with mixed results …

Basically the problem still exists … when I eject the Cruzer and plug it back in again it recognises drive f: (the small drive with U3 launcher in it) but it will not recognise drive g: (the 16gb drive) … device manager says its unallocated.

However, in following the procedure i did notice that if I unistall the “USB Mass Storage” from device manager … then plug the Cruzer back in, then the driver is reinstalled and all works fine (similar to rebooting with Cruzer plugged in). However, if i eject cruzer and plug back in i have the same problem again, and I have to uninstall “USB Mass Storage” again to get it to work.

Any ideas?



If the USB U3 drive is secured that happens. 

If you don’t have a password assigned to the device try assigning one, safely removing the device then reinserting it and removing the password.  Maybe some bit got set on and this may reset it.  No guarantees, just a thought.

Another thought, the link I posted before has been updated.  Maybe the update will solve your problem.

Chances are you have Samsung Kies installed either now or have in the past.  Follow the steps here and your problem will be solved.  I was literally pulling out my hair over this when I stumbled upon this fix and it worked instantly.

Easy solution for this, provided by Microsoft,

If you USB does not read the file because windows 7 simply will not read the old usb because it is no longer supported, either use a Windows XP machine, or install Microsoft virtual PC and Virtual XP and run that, set your usb in, let the virtual XP machine take control and it will work seemlessly.

Why is it that this thread gets a posting every 2 yrs???