U3 Windows 7 update now available!

WARNING: Before uninstalling or updating the U3 Launchpad, please manually backup your data.


The latest U3 Launchpad as of December 2009 is version 1.6.3.9.  This version is compatible with Windows 7.

 

Things to check for before updating:

1. Password protection must be disabled.
Please DISABLE password protection, If password protection is ENABLED, see instructions on how to disable password protection, then proceed with update.

2. Device version
If the Device Version on your flash drive is 2.17, 2.18, 2.19 or 2.20, you will NEED to run the U3 LP Installer in a Windows XP environment to do an update.

If you attempted to update the U3 Launchpad under a Windows 7 environment and is now experiencing errors, see answer ID 4432

Checking the Device Version
1. Open U3 Launchpad.
2. Mouse over Help and Support, and then click on About U3 Smart Drive.
3. Check the Device Version.


Once all of these information is verified, see Installing U3 Launchpad

Message Edited by sansamonsta on 08-16-2010 09:45 AM

Please, How  I can find this version.  The latest U3 Launchpad as of December 2009 is version 1.6.3.9. 

Version I can get is from 2007.

Thank you very much.

I also need new version. I had disabled password protection and I have internet connection of course. But when I click in launcpad “Check for updates” this happened:

![](file://localhost/C:/Users/luk/Desktop/screenshot.1.png)

 “The server can not be accessed. Please check your Internet connection and try again.”

Where I can found new version of launchpad in my Windows 7?

What version of Launchpad do you have?

Autoupdates of anything U3 no longer work.

I use version: 1.6.1.2.

I need latest version (1.6.3.9.), so where can I found it?

download the launchpad installer stickied at the top of this board. use that to update U3. 

Updated my drive to the latest version launch pad and verified. Windows 7 still complains about not having any drive letters available. This works on 32 bit but not 64 bit so far in my investigation.

But it’s old driver update. I need latest driver update!

What version do you think it is?  Have you installed it?

Yes and it’s 1.6.1.2.

Installer installed version 1.6.1.2.

I have already version 1.6.1.2.

:cry: where can I found latest driver?

Cruzer Titanium 2GB worked great with Vista. When I moved to Windows 7 it no longer works. Repeated tries have resulted in absolutely zero support. Totally no solutions or offers to fix. Nice product.

I have an old Cruzer Micro 8Gb… worked with XP, worked with Vista, and works just fine with my new Windows 7

Launchpad Installer 1.6.3.9  

I dont speak english… sandisk sen dalga mı geçiyorsun milletle… güncellemeye anasayfadan girince hata veriyor güncellemiyor… güç bela güncelleme buluyoruz yine aynı hatayı veriyor… bu markadan flash bellek aldığıma pişmanım dedirttiniz be !!!

http://forums.sandisk.com/t5/Cruzer-flash-drives-Solid-State/U3-COM-What-s-up-with-U3-Website/td-p/185386

http://kb.sandisk.com/app/answers/detail/a_id/240

Umarım bu yardımcı olur

I have a Memorex Mini flash drive that came with U3 version 1, 0, 5, 17 preinstalled.  It ran great on Win XP but now I need to upgrade for my new PC running Win7.  I go to the update site and download the updater to my XP computer and plug in the flash drive, but when I run the installer it says the flash drive isn’t U3 compatible and I can’t load the software onto it.  How do I get the program to recognize the drive is U3 compatible and install the updated version?

You need to contact Memorex for support of their drives.  But I suspect they don’t support U3 any longer and you won’t be able to use your drive with Windows 7. 

 

IF your lucky your version of U3 will have the option to be Removed built in which will allow you to use the drive as an ordinary flash drive on Windows 7.  And I think if you don’t use the U3 password option Windows 7 will allow you to access the data files on the drive.

I know this is an old question, but for anybody else looking for version 1.6.3.9 the links are correct but on another page I found this

‘quote’

If the U3 Launchpad version on your U3 flash drive is 1.6.1.2 or lower, unplug the drive from the PC and repeat STEP 1 once more to update to the latest version.

Step 1 being Plug in flash drive, Run LPInstaller.exe.

So installing twice with removing drive between installs gave me v1.6.3.9 showing under About in Launchpad, if that doesn’t work try a third time for good measure.

I hope that helps. Good luck.

I have tried all options, and this is is Kind of Useless…

I have the Latest version 1.6.3. 2009.09.23

I and it’s not Working, Period… 

Sorry I forgot to Say, I have a Windows 7 64 bits… French Version

And by the way, works perfectly on a Windows XP Machine… From what theyr are telling…

Unfortunately, I would have to Reformat my PC to Install XP to reformat the USB key in order to make it work with Windows 7.

So My Conclusion, this is piece of Crap, software, and a Unresponsible company, selling USB key, in 2011.11.27 with no compatibility to Windows 7, and to Provide as a solution, fix my Software U3, on a Windows XP machine.

Probably made in China!!! with Chineese Software…

I’m about to just reformat all in NTFS, or other, I also have a Macbook Air (2011) and the U3 is USELESS on Mac Os Lion…

Not very Impressed either!!!

For My Friends at Sandisk, please note: There is more than US ENGLISH in the World…

So you should test your "Soft"wear, before releasing it, it’s really frustrating, to be the ginny pigs…

L.Palardy

Bachelor Computer Science 1986.

Montréal, Qc

Canada

FYI

  1. SanDisk hasn’t sold U3 since 2009 so if you recently bought one it wasn’t new.

  2. U3 1.6.1 runs fine in Windows 7.  Windows 7 32 bit.

3. Windows 7 64 bit is junk whose only purpose is to force you to buy NEW software.  If you have a problem with U3 complain to Microsoft.  They’re the problem.

  1. BTW Microsoft’s virtual XP mode might solve your problem. http://www.microsoft.com/windows/virtual-pc/download.aspx