U3 Windows 7 update now available!

EXTRA SOLUTIONS ***  (After applying update):

I have been frustrated by this problem for over six months and was CONVINCED that this U3 Launcher update did NOT work with Windows 7.  When I discovered that my U3 drive (after the update to 1…6.3.9) worked on some Windows 7 machines and not on others, I started to look for other causes.  In fact, this update does allow your U3 drive to run on Windows 7, however, if you tried to run your U3 drive on the machine prior to the update, the following issues on your PC may continue to prevent the drive from running.  The following steps got my drive working on my PC:

  1. The following article on TechSpot shows you how to remove old USB drivers that persist on your PC long after you remove your USB drive using an application called “Drivecleanup.exe” http://www.techspot.com/vb/topic145884.html .   This requires removal of all USB connections and a reboot before running the program and then another reboot.   When I ran this program it removed over 20 USB drivers including four old ones related to the San Disk U3 drive.

  2. After rebooting connect your U3 drive (make sure password protection is still turned off), however, stop the launcher from running if it starts to autorun.   Go to the U3 CDFS Drive (Usually labeled as CD drive E).  Right click on it and select Open.  Then Right-Click on the LaunchU3.exe file and select Properties.  Then select the Compatability Tab.  Check to see if your machine is trying to run this file in Compatability Mode for Win XP Service Pack 2 or 3 (Odds are it is from your prior attempts prior to the upgrade).  If it is, you do not want this.  Down at the bottom of this same tab, click on Change Settings for All Users.  When the dialog box opens UNCHECK the checkbox that says “Run This Program in Compatability Mode For:”  You want Windows 7 to treat the launcher as a file that will now run normally in Windows 7.  Click Apply.  

  3. Close out of everything, navigate back to your E drive.  Right click and open, then right click on the LaunchU3.exe file and select Run as Adminstrator.  Your U3 drive should now run normally on Windows 7.  Don’t forget to turn your password protection back on if you turned it off earlier.  After this, your U3 drive should start up normally as soon as you plug it in to your PC (assuming you don’t have autorun disabled on your PC).  

This worked for me after HOURS (actually days) of trying to get this driver update to work!  Good luck!

This option works for Windows 7 also, 64bit version.


Change the LaunchU3 Windows Compatibility mode to Vista SP2.

Trying this out at the moment. I want to see how it goes personally. 

Hello Friends

I also Looking for the  version but its not avalialbe on internet Please any sent me a like any one now about the site were it is avilable and friend also tell that howes the windows 7 compatibility of this software is this version is also perfome compatibility like the previous one avaliable in a market.friends please tell what the minimum system requires for the new version

what the minimum system requires for the new version

U3 can only be installed on SanDisk USB flash drives manufactured prior to December 09. All U3 compatible SanDisk USB flash drives will have the U3 Smart logo. If your product does not have the U3 logo it is NOT U3 compatible.


And if run on Windows 7 64-bit run it in Compatibility mode for Vista SP2.

Where is it possible to dowload the version of the launchpad ? Is it the last version ? When I download the launchad installer LPInstaller.exe, I get the version ! Thank you.

See this link: http://kb.sandisk.com/app/answers/detail/a_id/240/kw/u3/r_id/101834/sno/0

It will run fine on Windows 7 32-bit machines but on Windows 7 64-bit machines run LaunchU3 in Vista compatibility mode.

My launchpad version is more recent than the downloadable version, but it doesn’t work on  Window 7 32 bit.

Especially when I encrypt the Sandisk Cruser using the launchpad,  it doesn’t work on Windows 7.

  1. Is it possible to find version or 1.6.x.x ?

  2. If not : why is there a KB article " How do I update my U3 Launchpad on Windows 7 ? " and this topic " Re: U3 Windows 7 update now available! ",  refering to version  ?

Strangely every time somebody asks where to download the version of the launchpad, a deafening silence is made! :wink:

Sandisk decided for certain reasons not putting the recent version in download.
But Sandisk could supply at least correct information to avoid to customers to waste time pointlessly.

To respect customers is the best means to develop loyalty of them.

I already gave you the link.  I’m not going to read it to you. :stuck_out_tongue:

The link you gave me leads to the KB " Installing U3 Launchpad on a PC " that I already knew, as well as the KB " U3 Launchpad update for Windows 7 " which says to install v

But it’s not the link for v !?

How do you know it’s not?  Have you installed it to your U3 drive?

@i_lambert wrote:

The link you gave me leads to the KB " Installing U3 Launchpad on a PC " that I already knew, as well as the KB " U3 Launchpad update for Windows 7 " which says to install v

But it’s not the link for v !?

I could be wrong, but I believe that’s the link to download the Launchpad Installer which will in turn install the update. Whether or not it’s the version you want or not, you’ll have to try it and see, if you haven’t already.

In fact LPInstaller.exe downloads and installs the version of the launchpad, which seems to work under Windows 7.

The version mentioned in the tab Version of LPInstaller.exe is thus the version of the installer.

Hi there - I can always run my LaunchPad in my Windows 7 64-bit Professional, probably because I have the Compatibility Mode unchecked by default. However, I can never use the “Eject” feature of LaunchPad nor I can use the Windows “Safely Remove” feature to first disable the drive before physically unplugging it. Below is the error message I got when I tried to “Eject” it although there is absolutely no open docs or programs. I even tried to reboot my laptop, plug in the (empty) drive, run LaunchPad, let it sit over night in case there is anti-virus, indexing, or anything else that might be accessing the drive, and I still cannot eject or remove the drive without getting either U3 or Windows error message. Thoughts? U3 eject error message: “An error has occurred while attempting to eject the U3 smart drive. Please check for any open documents or programs running on the device and try again later.” Windows 7 Safely Remove error message: “Windows can’t stop your ‘SanDisk Cruzer US Device’ device because a program is still using it. Close any programs that might be using the device, and then try again later.”

Try running the LaunchPad in Compatibility Mode for Vista SP2.

Things that maybe using the drive include your AV, FW, or any other app that looks for malware, or apps looking for specific file types like pictures, movies, music, etc.

Tried the Vista SP2 compatibility mode, as well as other compatibility modes. None works. If I picked the XP modes, the launchpad won’t even run. Understand there are AV, FW or other apps that could potentially be accessing the drive but how long will they be accessing a virtually empty drive?

Does this utility help you?  ProEject  http://softwarespot.wordpress.com/software/proeject/

A failsafe option is to reboot and when the machine is down remove the USB drive.

I have release of U3 operating system with open office, fire fox, dmailer, skype; when I tried my key with my new netbook with windows 7 installed, I coudn’t run open office; then I tried again to run in compatibility mode of windows before 7 U3 and aafter open office and every thing worked well without updating U3 on the key. Very good result! Try you too. Best regards.

Uh, not quite.  Might be time to pull down this whole thread.

I had a very odd experience with this software (pre-update; version 1,6,1,2).  In or out of Compatibility Mode, the software started-up really fast, then disappeared from sight on my i-7 Win7 64 system.  The U-3 icon in my task bar then VANISHED as soon as I flew my mouse over it.  Didn’t even have to click.

  •  I prepared for this update by removing encryption from the drive; also tried downloading and installng in an XP SP 2 environment;

  • However, the hyperlink in this thread for downloading the Win 7 64 software update (below) is now VOID.

  • I believe Sandisk has “surrendered” on this matter, apparently no longer offers the update, and apparently no longer holds out hope that U3 software may be executed within the Win 7 64-bit operating system.

A shame, because this was simple, intuitive, and elegant stoftware – even if the encryption was “whole-drive” rather than file-by file.  Now the only way I can keep U-3 running and retain encryption is in a “no longer supported” O.S…