Sandisk Cruzer 16GB "USB Device not Recognized"


My little brother has borrowed a Sandisk Cruzer 16GB from a friend. He thought he’d better clean it well before giving it back to his friend and deleted some u3 file he didn’t know was important. Now whenever we plug the usb device in a Windows 7 pc we get the message “USB Device not Recognized”, there’s no storable drive we can detect anymore. (Tried it on 2 different Windows 7 machines)

Is there a way we can fix this?

Edit: Also tried this: but didn’t work either.


I am having a similar issue. I purchased a 32gb Cruzer on Friday to back up some work data while doing a reinstall. It worked over the weekend and even a few hours ago. Now it doesn’t work at all.

I’ve got the same problem, and I’ve tried the solution given in this website but my USB Flash drive is still not recognised by our office computers.

Appreciate if anyone could share another solutions, cos I have important documents that I want to retrieve. You can email it to


if this is a work computer make sure your network administrator does not have the USB ports disabled or toher wise blocking them 

my 16 gb sandisk usb flash drive cannot oopen to all computer

If the USB doesn not work on say, 3 computers and all of them are on admin account, pretty much, you need to check on the warranty at this point already.