Devices Not Recognised - Win7


I’m having a bit of an issue with 2 Drives, 1 is a Cruzer Blade, the other a Cruzer Orbit, both 16Gb.

Neither are recognised in Windows 7 without a bit of encouragement, the steps I have to follow are:

  1. Insert the drive

  2. Open device manager

  3. Select the drive under disk drives

  4. Uninstall

  5. Remove and re-insert the drive

After I have completed the above every time I insert either drive, they install drivers and work with no problems until I remove them again.

Does anyone have any suggestions how to avoid having to go through the above rigmarole every time?

:smiley:   Hi Murdoc187


Dear member of SanDisk Community, welcome.

Well, I think that the problem, not is of the two UFD, but if of some corrupt line, in the registry/USB of the PC.
Please, then we will use, two small portable applications (free), are third party tools, very simple to use:

- CCleaner 4.10                 
- USB Scrub Cleans 1.00

Then, analyze the following:

- In the _ Control Panel /Administrative Tools/Event Viewer:_ see if there is information on this item.
- See also, in the _ Task Manager ,_ the processes which are running, and see what are the necessary and what to delete.
- In the _ Control Panel /Administrative Tools/Computer Management/Device Management Tools:_ see if a USB icon is crossed out with red, or there is a yellow question mark, etc.

See, also, for a teaching with images, the links:


Luck, and then you tell us, what happened, please.

Regards, Alfred.                                  

It solely depends on the Windows drivers. What you can do is to perform a Windows Update. Hopefully, that will do the trick. 


Hmm… is there an echo, distorted… (and 5 days later…)


Well …at reviewing posts and user accounts, I found this …

1- doncht            -> (14-02-2013   to   30-03-2013)
2- dwaynnyt        -> (31-03-2013   to   26-05-2013)
3- rickyjm            -> (09-05-2013   to   25-10-2013)
4- jimmyghd       -> (29-10-2013   to   28-12-2013)
5- mikkirourke    -> (03-01-2014   to   02-03-2014)
6- markwahl       -> (07-03-2014   to   27-04-2014)
7- kitscht             -> (28-04-2014    to   06-06-2014)
8- Hirsche           - >(07-06-2014   to   …   Now   …   )      


Thanks for your reply, windows update shows no new drivers.  I have uninstalled the devices via Device Manager several times (every time I insert the drives) and still the same problem keeps re-occuring.

Hi, Cacho

I run a registry cleaner via PerfectDisk on a schedule so there should be no problems with that however, I have also used Ccleaner and no issues found.

USB Scrub removed a few devices however the same problem occured after initial insertion.

There are no errors in Event Viewer, no erronious tasks in Task Manager and no issues with USB in Device Manager.  The devices show up and say they working properly however they do not appear in My Computer

:smiley:   HI Murdoc187,

mmm … I’m sorry, please, make the following tests:

1- These two UFD, try them in other PCs, having WXP-sp3 and Win7, to see what happens.
2- Y into your PC, try other USB flash drives.

Luck, and then you tell us, what happened, please.

Regards, Afred.

:smiley:  Hi Murdoc187,

3- See also, in the _ Task Manager, _ the processes which are running, and see what are the necessary, and what to delete.
Because, there are some programs, that cause, system conflicts, by blocking the ports, such as: Samsung Kies, HTC Sync, etc.

4- Well… It seems, that is the registry of  your Win7.
See if you have a _ System Restore Point _, prior of this problem.

Luck, and then you tell us, what happened, please.

Regards, Afred.                                (Google Translated)

Uninstalled HTC Sync and now it seems to work perfectly. Thanks

:smileyvery-happy:   OK!    Enjoy!!!