SanDisk Cruzer Fit 32GB USB 2.0 Error Message


I have one of your SanDisk Cruzer Fit 32GB USB 2.0  memory “things” (Stick seems a litte odd to call it) that has begun to giving me problems. Now and then (several times a day) I get this Error Message “pop ups” telling me “USB Device isn’t recognized” or something like that (sorry, forgot the little thing at work, so I can’t plug it in and wait for error message). I have tried it in the three (3) USB ports on my lap top and it happens in all three (I have, just to be sure, tested other USB devices in the ports and they works just fine). Only solution I have come up with thus far is restrting my computer, but that keeps getting “boring” (just to stay PC here) when I have to do it over and over again.

Anyone got any Idea what to do?

Thanks in Advance


The USB relies on Windows drivers to work. Have you tried to do a Windows update so far?

Yes, I do Windows updates as often as they are released and I have also tried doing USB driver updates.

I’m no tech guy, so forgive me for asking a stupid question… wouldn’t “bad” USB drives also affect the other USB devices I have “hooked up” (mouse and mobile broadband router)? But they work just fine , and so does the SanDisk Ultra Fit 16GB USB 3.0 I had to borrow today.

It really bugs me, since I bought the “Cruzer” less than 2 months ago and it worked fine at first.