SanDisk cruzer Force 32gb not recognized

Hi Folks,

I have recently purchased a sandisk cruzer force 32gb ( the one in the shiny metal casing). Last week the drive would not be recognized by any of my pc’s (tried on laptop, then on pc, then even on a raspberry pi, …no luck). I thought perhaps some loose connection could be the culprit. As I desperately need access to my data, I tried all the “software” solutions first ( uninstall dirvers, rescan…etc). But there always is the popup coming, “Cannot be recognized”. As a last resort ( mind you I am interested in the data, not the drive integrity), against my better judgement I carefully opened up the drive to try and troubleshoot any loose connections ( I have had success with repairing similar drives in the past by simply resoldering connections). Now as I opened the drive, I was presented with a bleak prospect: it is all a self-contained pcb with no solder joints or potential for loose connections. Is there any way I can use the exposed pads to try and recover my data? Or is the chip hopelessly fried?

Any response is greatly apprecaited,

Cheers, Brave.

( i will try to post a pic later)

 Pic: sandisk cruzer force interior

Posting the image again