Was working, now NOT

Ok everyone, I had the clip, had some initial troubles, updated the firmware, everything was great.  Today I go to put it on the USB and sign into Rhapsody, and nada, nothing.  It doesn’t recognize my clip, I have tried, de-authorizing my computer and my clip.  My computer re-authorized, I can’t re-authorize my clip.  I tried under settings on the clip to change the USB options.  Nothing.  I reset and then reformated the clip.  Nothing, now I have a clip with no music, and 137 songs on Rhapsody.  I try to add my device it says Rhapsody needs to be updated.  I updated Rhapsody, but I keep getting the same message, if i try to re-update again, it says the current Rhapsody is already running…HELP!  I am lost and don’t know what to do!

does your computer recognize your clip? or is it just rhapsody that doesn’t see it.

When I go to my computer it is not recognized.  (I think that is what you are asking) if not, how do I find out if my computer recognizes it?

it seems your computer cannot detect your device.  does your clip show “connected” screen when plugged into pc? have you tried a different USB port?

I haven’t changed USB ports.  When it is connected to the USB it says connected and it is charging.  I didn’t think I would need to try a new one.

The only new change is the installation of McAfee anti-virus within the last few days.

was it after the installation of mcafee that the clip started not being detected?

I’m wondering if mcafee has blocked your device, probably not, but I haven’t used mcafee for a while. (AVG anti-virus is very good and free). 

Yes it was working and recognizing it it before the McAfee, but on the other hand, my kids were using it also.  I can’t be positive they weren’t pushing buttons, and trying to add music either.  They are not little, 14 and 15, but at the same time, don’t take the time to read things before clicking yes, etc.

as of now the clip has no music on it, it is not recognized by Rhapsody or my computer.  If I change the USB on the settings to read either MSC or MTP (not sure which one) i can get Rhapsody to recognize it and my computer, but I have the Rhapsody on the go subscription and it won’t let me drag and drop from my library, it wants me to pay for the songs.  There is a little $ sign on the left side of Rhapsody under Sources.  I tried to re-authorize the clip, but it won’t let me do that either.

I am sorry this is so long, I am just not very good at all of this.  Which is why I loved the clip, I connected joined Rhapsody, dragged and dropped.  Viola music.  I did manage to update the firmware following the directions from here.

Maybe I will exchange the clip for a new one and give it a try. 

If anyone can help I would appreciate it.

wait, we’ve got something here!  your clip is detected in MSC mode! so if in MTP mode your comptuer doesn’t detect it, I’m assuming there is either:

  1. something wrong with your MTP drivers

  2. mcafee is blocking those drivers.

I suggest trying the following:

1)  First , try unistalling mcafee and see if your clip works again. incidently you can reinstall mcafee again, and see if the clip stops working. if so we can blame mcafee

  1. its possible during mcafee install, something happened to the mtp drivers. uninstall and reinstall Windows Media Player 11. This should reinitialize your mtp drivers. Be sure when your uninstalling, to remove the program AND the runtime.

Try the first step (removing mcafee).


Thanks, I will go home today and try that!  I appreciate it!!!

Hey…removed the McAfee, no good.  I restored the computer.  Can get the computer and Rhapsody to recognize but will not authorize the player.  It insists that I purchase all of the music.  I have a current Rhapsody to go subscription.  I think I will bring it back to BB and try a new one.  I do not know what else to do.

ok so now rhapsody can recognize the device in mtp, so we’ve solved one thing. does rhapsody display an error message when it can’t authorize? or does something else happen.

please describe or detail what happens when you try to authorize and it fails.

Okay…when I start Rhapsody it signs into my account.  My music shows up under my library.  Sansa Clip says connected, and charging.

It shows the Sansa Clip under Sources, I right click on it, it says Device options, create a new playlist, format device and disconnect.

If you click on device options it says Music, then a blank box, select all, select none, device help

format: MP3, quality 128KPBS Stereo.

If I go to manage my account, it has my authorized computer, and says you have 3 remaining device authorizations, right click on the device icon in the left pane and choose “authorize” but its not there.

What should the USB be on under settings on the device.  It is currently under auto detect.  I might add there is a red S on the bottom right tool bar on my screen that kind of rolls (like a slot machine)

Try this:

Close Rhapsody.

Navigate with your computer to main drive this directory where [user name] is the name of the user that logs into windows:

C:\Documents and Settings[user name]\Application Data\Real 

Delete all contents inside this folder.

This should reset all preferences, settings, confirations and memory of devices with Rhapsody.

Now open Rhapsody and connect your Clip in MTP mode.

Is the authorize function available for it now?   

If it doesn’t, please choose help > about in rhapsody, and tell me the version and build number of your Rhapsody. 

Sorry to sound ignorant.  I have no idea where to find this.  When we start our computer it just comes up, there is no user name, etc. 

Would I find it under my computer?  Under start?

If you navigate to :

C:\Documents and Settings\

it’ll show a few folders. if you only see all users, than that is the folder it should be in. 

also you will need to unhide hidden folders and system folders. 

Message Edited by thoma on 06-20-2008 02:59 PM

I found C: document and settings, and under that is Administrator, Adminstrator.your (something or other), all users and owner

Under all users I get, desktop, favorites, shared documents, start and symantec temporary folders

try administrator, if not try user and owner, only one folder will have the specified destination.

please be sure to unhide hidden folders and files, I will upload a picture on how to do it

select “show hidden files and folders” and uncheck “hide protected operating system files”