Sansa E270 not working

This was recently purchased for my boyfriend. I have the E250 and it works just fine.

There are several problems taking place.

  1. music doesn’t show up on player any longer

  2. when plugged into the computer, it either a.) doesn’t show up b.) the player acts like its charging but it continuously says low battery c.)does nothing

  3. upon turning the E270 on, it either says a.) “battery is too low, system shutdown” b.) "Not enough space for MD. Please free 6gb of space"C.) or it gets stuck on the SanDisk startup screen.

4.) and it gets stuck/frozen on a screen and wont do anything.

How do I fix this? I’ve already done the firmware updates last month when we had issues putting music on the player. I don’t know what else to do.

Thanks for the help!

Could be any number of things, including but not limited to:

  1. Dead battery.
  2. Dirty battery contacts.
  3. Bad cable.
  4. Dislodged memory chip from motherboard (inside).
  5. Corrupted firmware.
  6. Corrupted files.

Of these, the cheapest and easiest to check out is the cable. Try the one from the player you know works. You can also try re-seating the battery. It pops in & out like many cell phone batteries. Check the contacts for corrosion or muck while you’ve got it out. Look the battery over for any signs of leakage. If there are any, get rid of it and get another one. Leave the battery out for a minute or two to let any residual memory dissipate, just in case it was stuck in a loop or something. Plug the battery back in and see if anything changes.

Let us know how you make out with this first and if necessary, we can tackle the harder stuff. :smiley:

Thanks for responding! It isn’t the cable because I’ve used both his cable and my cable. I tried removing the battery and everything you said and now when I start it up it’s stuck on the SanDisk startup screen…


I tried rebooting again and it appeared to work. Turned it off, rebooted and now its frozen on SanDisk startup again. So weird…

Sounds like your firmware could be corrupted. Go here and download the .zip file (for your geographical location) and follow the step-by-step instructions for manual install. Don’t use the Sansa Updater. Hopefully, that will solve it.

This is so frustrating! I tried the link but it suggets plugging the Sansa into the computer. But it doesn’t recognize the player. And now it keeps rebooting itself, rebooting itself over and over. The only way to stop it is to take the battery out. Arrg!

Go ahead and take the battery out then and plug it into your computer in order to update the firmware. If it works, things should be right as rain when you put the battery back in and it’s under its own power.

list me the service centres in tamilnadu