E 200 FROZEN, NO SCREEN IMAGE, COMPUTER DOES NOT RECOGNIZE IT

Please help! my wife loves this thing!  was transferring songs the other day via drop and drag.  Unplugged device from computer. It froze. Screen went weird with horizontal grey lines.  Have tried the ‘reset’ with power button - at least it will turn off. The computer does not recognize there is a device there when I hook it up and turn it on.  Now, on power on, I gee the SanDisk welcome page, then screen reverts to the grey horizontal lines.   Anybody had this challenge before?  What did you do to fix it?

First step: Open the back–four little screws, be careful not to lose them–and take out the battery for half a minute and put it back in. It’s a different reset than the power button.

Do you know if you have a v1 Sansa (more than a year old) or a v2 (released about a year ago, but both v1s and v2s were on sale all year)? Look on the back: E200 is probably a v1, E200v2 is probably a v2–but only probably.

There are different steps if the battery trick doesn’t work, so don’t give up. Your marriage may still be saved. 

I had the same problem with the E250 of my girlfriend. And i fixed it. Look here

Use Recovery Mode to format your unit.

thanks, tried the battery trick - no luck.  Will open it again and see if we have V1 or V2.

Any further suggestions on what we can try?

And again, thanks

hi and thanks - only one challenge - our device won’t go to any mode - sorta just sits there like a slug. But I’ll try the call to 888Sandisk and see what happens there. 



You might have a hardware defect, in which case there’s probably nothing you can do to fix it.  It might be a firmware issue or it might simply be you need to reformat the device.

First, try to connect in recovery mode:

  1. Turn player off.
  2. Push HOLD button to locked position.
  3. Press and hold RECORD while connecting to PC.
  4. Release RECORD after seeing “welcome to recovery mode” on the player’s LCD.

Congratulations, you are now connected in recovery mode.  Open Windows Explorer and you should see a new removable drive labeled 16MB-FORMAT.  Despite what the label might imply, DO NOT ATTEMPT TO FORMAT THE 16MB-FORMAT VOLUME!

We will tell the player to format itself, but we will not directly format the 16MB-FORMAT volume.  To do this, right-click on the 16MB-FORMAT drive while viewing its root directory.  Select New and create a new folder.  Name this folder sansa.fmt and then use the safely remove hardware icon in the system tray (or right-click on 16MB-FORMAT and select eject).  Upon disconnecting from the computer, carefully watch the player’s LCD screen for any messages and make a note of them.  Hopefully it will say formatting… and then format complete and then reboot and work as normally.  You will need to reload all of your media content after the format

I’m guessing formatting has about a 70% chance of fixing the issue.  If it doesn’t fix it, the next step is to try reloading the firmware.  Go to this thread and download the latest firmware for the v1 players.  This should be a .zip file with 2 files inside it: a .ROM file and a .MI4 file.  Extract those files to a temporary directory where you’ll be able to find them later.  Note: the files are inside a folder named “A” within the .zip archive.

Redo the instructions above for getting connected in recovery mode.  This time, instead of creating a new folder named sansa.fmt into the 16MB-FORMAT volume’s root directory, we will copy the .ROM and .MI4 files there.  Those 2 files should be in the 16MB-FORMAT root directory.  Do not put the “A” folder on the player, just the 2 files inside it.  Now do the safely remove hardware icon thing and unplug the player.  It will update its firmware (MI4) and bootloader (ROM) and then restart itself, hopefully coming up into the language selection screen.

Great help and good advice - Markster - whoever and where ever you may be.  My wife will be happy - and like they say  " happy wife, happy life!"  ![](file:///C:/DOCUME%7E1/GRAYJO%7E1/LOCALS%7E1/Temp/moz-screenshot-6.jpg)

My e280 was frozen on the SanDisk logo screen when you first boot up. So far, your method seems to have worked for me too. It’s currently syncing with the library in Windows Media Player.

Thanks from me too.

thanks for the info Markster

that solved my problem of having “bad tracks”, funky named, folders and not being able to delete files from my player through windows. 

How long does the formatting take on a E260? Mine’s been “formatting” for at least 20 minutes. :frowning:

TIA

okay i been on here all tryinng to figure something out for mine until i got really mad n just blew into the part where to charger goes in to and iht works its ben good since then make sure when yu blow into iht the mp3 is on