(e280) Problems still after a reformat: Possibly worse. How to know when the thing is toast?

I think my absolute last hope for this thing is to use the Linux e200 tool, which of course seems like it’s gonna be the hardest thing to do, cuz I don’t have Linux.  Here’s a recap of my woes:

  1. Some stuff went down (battery wasn’t being recognized, connection to computer was erratic and useless, etc), so I reloaded the firmware.  NO CHANGE

  2. Formatted the device using recovery mode.  Still no change.

  3. Tried formatting again in MTP mode (i couldn’t recall if I was in MSC mode or not the previous time), and noticed that when I unplugged the sansa, the device immediately went dead (as in, no power).

   a. HOWEVER when i plug it back into a computer, normally, with the hold button OFF, it connects and says, “Connected”  (an improvement) right after it says “Database error. Free 6MB.” (not an improvement).  But it shows that the battery is charging (and improvement, as earlier the battery would not charge nor show that it was charging).  But the device DOES NOT SHOW UP ON MY COMPUTER.

  1. Attempting to reformat this way now is no longer possibly because as soon as I unplug the device from the computer it goes dead right as the screen says, “formatting…”.  Maybe it just formats faster though because there is nothing on the player anymore (as it’s already been formatted)?

WHAT TO DO NOW?  Oh Lord how long?


If the device goes blank (turns off without any indications) immediately upon disconnect, it is not switching over to battery power.  Normally, the battery will take over as soon as the device is unplugged from a power source, be it an AC adaptor or the USB port.

It’s possible that you simply have a bad battery module or a poor contact.  Carefully remove the four rear panel screws (#00 Phillips screwdriver), being careful not to lose the small screws.  Remove the plate (it lifts easily using a fingernail), and remove the battery module.

Check the three contacts for any dirt or corrosion, as well as the three spring contacts on the Sansa.  Replacement battery modules are available from Radio Shack as well as via places like Amazon or eBay.  I prefer to purchase from a known vendor.

Bob  :smileyvery-happy:

Gee thanks Bob, did you become a Sansa Guru by dispensing such obvious advice as ‘check the battery, perhaps go buy a new one’ to people like me?  I of course tried that before doing such laborous hours-long tasks such as reading the forums for half the day, then posting questions, then updating the firmware, then reformatting, with many different cold-start/forced factory mode turn-ons and shut-downs and battery openenings and pushings and closings.  I need real advice here that comes from real experience; this device has gone through a lot of problems in the last 3 weeks and I’m sure it has nothing to do with something as simple as a battery replacement.  Thanks for trying though, but I’m afraid that your posting will not be green lighted on this particular thread.

Hey, I understand your frustration, but I fail to see the logic in lashing out against the one person who has volunteered to assist you.  I have no way of determining just what has taken place on your end, nor do I have any clue, in a brief post, what a user’s level of expertise, and patience, may be.

You have mentioned that Recovery Mode has been tried, as well as formatting.  Recovery mode exposes the reserved partition, not the root directory of the data partition.  Windows readily offers the option of formatting the open partition, and a v1 device will instantly have no firmware image to boot with.  Thus, I must be cautious at the cost of seeming repetitive.

Let’s look a wee bit deeper.  You have listed several overlapping steps, and then resorted to CAPS in your response.  The human factor gets multiplied by the digital factor.  So yes, we must fall back to the basics.

Further, you mention that the device blanks out as soon as it is disconnected.  This will not happen when the firmware is being installed, in fact, the device may power down after the firmware mi4 code is moved to the reserved partition, replacing the existing file.  We have no confirmation that “the firmware has been installed”.  All we see is that the device powered off.

A bad battery may operate the device for several seconds, but as soon as the display plus a file swapping operation in memory involving blocks of data and the processor, our current demand peaks.  If it’s a battery module or connection, this is when a power issue is most likely to take place.

I won’t even attempt to count the hours I have spent working with these devices, in my pocket, on various computer platforms, or on the test bench, including replacing SMT devices and chips.  If you want “real answers”, perhaps one should rethink the post before zipping the mouse over to the Post button.

I have no concern whatsoever for status or whether a reply is flagged green.  Ask anyone here.  My concern is to help you, for what that’s worth.  

Plug your device into an AC USB charger (no data) and see if it powers up or responds.  Or, transfer the valid mi4 and rom files, then slowly pull the USB connection until the data lines open.  DO NOT unplug completely.  The device will refresh as soon as the data session closes, and will run on the USB 5v line only.  If this is the case, reread the earlier post.  I did not state to replace the battery, but to check it, and stated further that they are available locally.

Bob  :smileyvery-happy:


Message Edited by neutron_bob on 06-27-2010 01:51 PM