Sansa Clip + stuck on flower

I put music on my player and unplugged it from the computer. When It was refreshing it was stuck for about 10 minutes. So I decided to turn it off. Well when I tried to turn it on it Shows the Sansa logo, then the flower. After that it quickly reboots and repeats the Sansa logo, then the flower logo but it never leaves the flower logo. 

I’ve tried holding the power button down for 20 seconds and it cuts the player off, but it doesn’t solve my problem. I don’t have access to my music, settings, or anything. I can’t even plug it up to the computer. 

Can someone please help? 

Here’s a video of my problem too.

I hate to suggest something drastic so early, but if trying a reset a few more times doesn’t help, can you connect the player to your computer?  If so, you might try manually reapplying the latest firmware (see the firmware uograde sticky thread at the top of the fourm).  And if that doesn’t help, you then might try reformatting the player using Windows (note:  this will delete any content that you have put onto the player).  

I can’t connect it to the computer. It stays on the flower no matter what.

Quite the coincidence, 2 of these in one day?

FYI, your player probably wasn’t “stuck”, but just thinking. The database refresh cycle can take a while parsing the information from the ID3 tags of all the files on the player and memory card, if present. This can take up to 20 miuntes or so, depending on how full the player (and card) is, or how many files it has to read.

Indeed, we both got exactly the same issue at around the same time. Is this epidemic?

On my side, I called Tech Support and I’m going to make it replaced next week…
But I’ll follow this thread too if you find a solution before!