Sansa Clip+ problems

Hi all,
I just signed up to this Forum due to a problem I’m having with my MP3 player.I purchased a SanDisk Sansa Clip+ 8 GB MP3 Player from Amazon on July 20, 2014.At that time I decided to also purchase the extended protection plan.
The player worked well until this past week when I noticed that the battery is charging just a bit,but is then indicating that it is full.When I attempt to play something,the “full” indication only lasts for a very short period,maybe a few minutes,then the battery icon shows the battery with a line through it,and it shuts down.
Also,when I plug it into my IMac to charge it,it no longer appears on the IMac desktop,so I cannot access it anymore.If anyone has any ideas on how to solve these problems,I would surely appreciate hearing them!

Thanks much,


While I’m posting I thought I should also ask this question:

If my player still works,but not fully,will I still be able to get a new one through my protection plan.If I recall correctly,I have the Foursquare plan.(I also noticed that on Amazon it states that my model is now discontinued)

I just realized that I posted this in the wrong category.Mods please move if possible to the Clip + category.Thanks

What are you using to charge the player? Did you try charging it using an AC usb charger(or mini usb cell phone charger-make sure it is 5 volts before connecting it to the player) rather than your computer?  Some computers put out very little power at a front usb port, with the rear ports putting out more power. Notebooks typically put out low power to the usb ports when they are running on battery power, but put out much more power to the usb port while the notebook is connected and charging. If the player isn’t charging properly, it is either due to a power source not puttting out enough current(mah), a defective usb cable, or a problem with the player battery. Did you try using a different usb cable?

The battery indicator on the player often gets out of whack. Playing the player until it stops from a lack of power, then giving it a long charge with a good charger typically resets the charge indicator, although sometimes a second cycle of playing the player until it stops, then giving it a long charge might be needed to reset the battery indicator.

Thanks for the reply.I’ve only used the USB connection to my MAC to charge it since the beginning,and it has always worked.

Since I first posted,it is charging OK again but now there is another problem.About a week ago,I started getting this message:

“Not enough space for music DB.Please free 90 MB.” (There is actually about 400 MB’s free on the player)At first this message was intermittent,sometimes when I connected it to my computer the message would not appear,allowing me to scan and repair it using the “Disk Utility” on my MAC.Then it would work for a day or so.

Today,the message appears everytime I turn it on,anf then the player will shut off after a few seconds.So now I cannot do anything with it.

There must be some damage if I keep getting these bizarre occurances such as the battery problem and now this message.

I’m ready to turn it in for a replacement using my replacement policy that I bought with the player,unless you can help with a solution.


Here’s a few ideas to try. Or maybe you have resolved your problems by now?

-> Maybe try recharging your Clip+ player using an AC adaptor that is designed for USB connected devices (output = 5V DC and 1.0 amp). Maybe leave it charging for at least 3 hours?

-> Seems like your Music database and maybe the file storage area inside your device (not the external SD card) is messed up?

     I found these instructions on page 26 of the Clip+ owner’s manual:   


           WARNING: Formatting will erase all your data.

           1. Select Format.

           2. Confirm your choice by selecting Yes or No.

-> Maybe see if your Clip+ will behave normally using music files copied onto the external SD card for a while?

Thanks for the info.It seems to be charging OK lately.As for the “not enough space” problem,I finally was able to get it to turn on and let me access it on my computer desktop(by repeatedly turning it on and off).When I could access the player,I copied all of the music off of it,and deleted it off the player.

Then I ran the MAC disk utility on the player,which repaired some issues,which appeared to be minor.I then copied the music back onto the player,and deleted a few more files just to be safe,so as to be sure I had enough space left on the player.

These steps have seemed to work(so far).It has been running OK now for a few days.

I have a few questions though.

Does the player allow one to copy more than the alotted memory limit on the device?

When using the “format” feature that is available on the player,do I need to reinstall the “system” files afterwards,or does the player “recreate” them?

Just an FYI,I did have a 32 GB memory card in the player,but while trying to get the player to work,removed the card and lost it somewhere in my car.

It’s been without the memory card for about 2 weeks now.I ordered another and will install it when it arrives.At least I know that the memory card was not the problem,as the errors persisted while it was removed.

I am contributing to the Sansa Clip+ Forum as a 2-week owner of a SanDisk Clip Sport.  I think these two units have major similarities. I do not own a Sansa Clip+.

After a few minutes of Google searching your most recent questions, I am wondering if you should not buy a 32G SD card and stick to using 16 GB SD cards.

     Looks like the the Clip+ has a music file limit of 6000 or 6500 songs.

    I am confused if this limit applies to the internal player memory OR, a combination of the internal memory with the SD card. OR, maybe the internal memory and the SD card each have a 6000-6500 music file limit.  

   I imagine that a 32 GB SD card will hold way more than 6500 music files, and the excess above 6500 may be ignored by the Clip+ music database ???

I think (?) the Sansa Clip+ internal Settings Format Command will just clean out all your personal settings and restore the player to original condition, retaining whatever version of firmware you currently have installed.

     (Do not use any computer based format command on the internal player memory.)

What Firmware version are you using?  Maybe check out all the messages in this very long thread:

Best Wishes

DFELD2005, the Clip Sport is very different than the Clip+. They even use a different processor. The Clip+ combines the contents of internal memory  with card memory into a single database. The Clip Sport keeps  internal memory contents in a separate database from card memory. 

The Clip+ has a song limit listed as 8,000 songs, however this can vary from around 5,000 to 10,000 as the limit is a limit on the size of the database. How much space each song takes up in the database depends on its file structure, and length of its tags. The Clip sport is listed as having a 2,000 song limit for each of card memory and internal memory, however with the new experimental firmware for the Sport, these limits are raised to 4,000 songs each.

I have both the Clip+ and Clip Sport. I had the Clip+ for 6 years, and the Clip Sport for almost a year and a half.

I used the Clip+ for a few years with the Sandisk firmware, then put Rockbox on it. With Rockbox, most of the limitations of the Sandisk firmware are removed. 

Thanks for all the helpful info and interesting facts about these players.Right now my Clip is working OK,I’m guessing it was a memory issue,with too much data on the player.I’m a bit surprised that the player allowed me to “overfill” it without giving me some kind of advance warning though.

One strange thing I did notice,today when I was charging the battery through the USB cable to my MAC,I noticed that the player kept playing a song while it charged.It was a song I had been playing right before shutting the player down.I tried to change the menu setting so it would’nt be on the song but it kept reverting back to playing the song.Strange!I’m glad that the player charged OK though!

Well I thought that I would post the next  problem that my Clip is having.As I stated in my last post,a few days ago it started staying on the last song played while charging.If I try and go to a new folder,it reverts back to the last played song again.It is charging OK,but it is also not showing up on my computer desktop again so I can’t access it that way.

This development is frustrating as I just bought a 32 GB memory card to replace the one I had lost a few weeks back.I put the empty card into the player,and the player sees it,but I can’t copy anything onto it as the player does’nt show up on the desktop.

I’m going to have to remove the card,place it into a adapter,then into a card reader and copy the music files onto it that way.

I’m beginning to wonder what kind of problem I’m going to have next with this player.:mansad:

I think you mentioned using a Mac computer to manage your Sansa device and the micro SD card?

I am wondering if your problems with the 32gb micro SD card relate to the challenging problem Mac OSX causes when trying to read NTFS formatted drives?  Are you aware of this situation?  Do you have access to any old PC computer and test read/write access to your Sansa device and micro SD card???

A few years ago I bought version 10 of Paragon software “NTFS for Mac”.  Every year Paragon issues a new version ($19/ yr) to match the latest version of Mac OSX. Etc, etc etc.

I am trying to stay with version 10, but I am reading that version 14 will be necessary for El Capitan version of OSX.

Here is a general link to the situation I am thinking may relate to your current problem using a Mac for NTFS formatted drives.

(Or maybe I am way off target that this idea relates to your original question?)

I am wondering if you are experiencing problems related to Mac OSX inability to write data on external high capacity drives formatted as NTFS?

Maybe check out the information at this web-link and see if this problem could be related to your Mac not detecting your new 32gb micro SD card??

First, if you can get it going at all, go to Settings/System Settings and change it to MSC for use with the Mac. It’s probably on Auto, which sends it to MSC, but could be acting up.

Also try using a wall charger  (or even a car charger)  if you have one rather than going to the computer.

Next,  try is a different cord. If your computer isn’t recognizing it and it is in MSC mode,  that would suggest that the data connection has gone bad.

it is a standard miniUSB connection–you may have a camera or something that uses one, or maybe you can borrow one. Or you could get a generic cord from Amazon for a few dollars.

Once you get a computer connection, replace the firmware using the Manual method that is explained in the thread. Don’t install the Updater (I don’t think you can on a Mac anyway). Basically you download the firmware, unzip it and drag the unzipped folder onto the Clip in MSC Mode. If there’s a firmware glitch that could possibly mess up the charge indicator.

And if none of that works, the battery connection inside may be bad and you need to replace the Sansa.  If your protection plan can’t get a  Clip+ any more, see if you can demand a Zip, which is slightly more Mac compatible–it plays .m4a files from iTunes.  The Sport and Jam, newer models, are not as good, so be pushy if you have to.

Make sure the USB Mode is MSC. Settings/System Settings/USB Mode. Auto should send it to MSC with the Mac, but Auto anything is not entirely reliable. If it somehow got moved into MTP mode, that’s to work with Windows Media Player and is probably making your Mac not see it.

Also, try a different cord in case that’s the problem.

And it wouldn’t hurt to reinstall the firmware using the Manual method in the sticky thread near the top. Forget the Updater (I don’t think that works on the Mac anyway)–just download the .zip file, unzip it and drag it over to the Sansa Clip driveletter.

There is a limit on the size of the database–the index that gathers Artist/Album/TItle data from the ID3 tags in the files. That’s basically a text file and there is a limit on the number of characters in it.  So if you have longer filenames fewer will fit, but most folks hit the wall at about 5,000.

The Sansa firmware was programmed before 32GB cards were around and for some inexplicable reason they left the database limit.

You’ll know you’ve hit the limit if the end of the alphabet isn’t shown.

If that happens, you can navigate by Folders, by clicking down past Artist, Album, Song, etc. and see the list that way.

Or if you’re comfortable with computers you can go to and install their alternate firmware, with no database limit, alongside the Sansa firmware.

Meanwhile, formatting leaves the firmware alone. It’s in a separate partition. It’s not like formatting a drive on your computer and having to reinstall the operating system.

Maybe you are experiencing Mac OSX problems reading external drives that are formatted in NTFS?

Check out the Paragon homepage for more information. 

The card should be formatted  in FAT32, not NTFS, or the Clip won’t read it. So that’s not the problem. 

Thanks for the info.Lot’s of good info.I changed the mode from Auto detect to MSC as you suggested,and nothing changed.

I will have to go buy a new USB cord and try that.I’m also going to try and reinstall the firmware.

As of right now,here is what my player is doing,and not doing:

It’s charging OK.

It’s seeing the 32 GB card and playing files off of it.

It’s turning on and off OK.

It’s not seeing the internal memory any more.

It still “sticks” on the last song played while charging.

It’s not “refreshing the media” anymore.It used to do that every time I unplugged it from charging.

After my last post(the one before this current one) I got frustrated and decided to reset the factory settings and also “format” the player using the format feature within the player.

That’s when I lost all my music off of my internal memory,and since the player is not appearing on my MAC desktop anymore,I cannot access the internal memory,so it is now empty.(I did’nt have the external card in the player when I reformatted.)

I’m going to try and connect it to a PC and see if anything happens.

I think I’ll check out Rockbox too.

DFELD2005,thanks for your input.Yes the player is formatted FAT32.

Go to Settings/System Settings/Info. Does that show the internal memory with a lot of empty space?

Since you formatted the unit, it wiped out any files you added to internal memory, so it makes sense that it’s not showing anything you had there. It should only refresh if you’ve added or changed something–but it’s possible the Mac does some kind of funny business that makes it refresh each time.

Having  formatted, you’ve ruled out a bad file in the internal memory. Which leaves  two possibilities: a bad cord or a firmware glitch.

Connect it to a PC. If the cord is good it will show up as two drives: SANSA CLIP (internal memory) and Removable Disc (the card slot).  If it does, download the firmware from the sticky thread near the top of the forum, unzip it and drag the unzipped folder (or it might just be a .bin file, I forget) onto the SANSA CLIP driveletter.  When you disconnect it will update the firmware.

OK,it took awhile,but I finally got it hooked up to a PC,using the same USB cord I used on the MAC,the PC could see the internal memory.I did a firmware update and can now access the internal memory,even on my MAC,which is where I filled the internal memory up with songs and it seems OK right now.

The problem I’m having now is with the 32 GB card I have in the player.It’s new because I lost the last one while screwing around with my player in my car.

Anyway,I placed the new card in,started filling it up with music,and found that after putting only 10 Gigs of stuff on the card any more MP3’s that I tried to copy over would not play.I’m guessing that for some reason they are becoming corrupted,but I cannot figure out why.

Are you loading from your Mac?  A Mac can add “extra” admin. files that can choke non-Apple devices.  A solution:  use freeware Hidden Cleaner to transfer files.

1 Like