Sansa Clip 4GB works only when connected via USB to the computer.

I’ve been using this mp3 for about 2 years, and it hasn’t given me any problems till today.
Actually what happened was, I was syncing some songs to my mp3, memory was almost full, it finished syncing, but the display still showed reading.
I was in a hurry and so I plugged out and rushed for work, on my way I tried switching it on, but it wouldn’t switch on, in the evening I plugged it into my computer, it started as usual, I deleted a few songs, waited for it charge and plugged it out, the screen went blank instantly. I tried reset and stuff, didn’t help.

I then formatted it entirely, tried a manual firmware update, which after a long time was successful, it still works on the USB power supply, like even when the computer is in sleep. It just goes blank when it’s off the USB.  

What am I supposed to do.

i"ve charged it like for 5 hours, no change, doesn’t even show the usual BATTERY LOW, just blank as soon as disconnected.


It sounds like the battery has died completely, or one of the leads has come loose. You may be able to repair it, but you’ll have to open the player (not an easy process in itself, it’s glued together. The little bugger wasn’t made to be user-serviced.) and resolder a pretty small wire. You could also try conductive glue.

Hey thanks man, so that means it’s entirely a battery problem huh?
I’ll try opening it and solder or stuff.

But doesn’t it have anything to do with firware? It was first on ver 1.01.16 and after the manual firware upgrade it’s on ver 1.01.35.

Plus after the upgrade I synced some songs onto it, for which Media Player showed succesful, but when I put the computer on sleep with the mp3 on the USB (cause it still works on the USB power) the Clip switches on and works normally, only the battery indicator shows it’s charging. When I checked the music library it showed no songs ! The radio works sometimes though.

Does that ring any bell? 
Could you please help me out on this.