My Clip + is Dead :(


yesterday i was listening to music as usual when suddenly my ‘brain’ turned off. Battery was something about 80%.

Now it wont turn on again. Even PC does not recognize the clip ( there is a bling sound when connecting but thats all. clip remains off - screen doesnt show connected icon ). I tried reseting at least 60 times in different time spares, holding power button 10 secs, 60sec and even more but nothing happened. Also connecting it to the PC in MSC mode (spelled well?) didnt work ( i held middle button and connected, also did multiple combinations). So i did everything + i checked that battery is well connected inside.

Please help me i cant imagine saturday without my brain :frowning:

Am not sure what’s going on.  But sometimes leaving the player plugged into a power source for a day or two can cause the player to come back to life.  

well, second day and still nothing happening. im opened for all ideas

still nothing :frowning:

is there any other way to restet it?

The only thing I can think of is to let the player sit for a week or more so that the battery drains completely.  It may seem dead but it’s probably just in a frozen state with a dark screen.  Kind of like in a coma.  Then plug it into a power source and leave it connected for a couple of days and then see if it’ll start up again.

How long have you had the player?  If you bought it new, you may be able to get a warranty replacement from Sandisk if you can’t get it to working again.

thanks for advice. I got the clip half year ago, so i still can use warranty. I’ll be patient than :wink:

If it will come back to earth i’ll let you know.

Good to hear about the warrnty, if you’re forced to use it.  Hopefully, the drain and charge possibility noted above will work–it sometimes does.

Good to hear about the warranty, if you’re forced to use it.  Hopefully, the drain and charge possibility noted above will work–it sometimes does.

But how is it that its supposed to discharge when its off??

I’m sure baterry is now 100% full. Even if clip still uses some energy it will take ages to totally discharge.

try installing the firmware.

I have had other players go deaad and revive when I reinsalled the firmware.

Might be worth a try:

Turn on the player with the power switch and hold the menu button firmly for 10 to 15 secs.I don’t know why but that worked on mine!


Same issue with my  new refurbished 4 GB Clip+, and  the replacement too. They both worked fine until power went down to about 60%, then they turned off and now they won’t turn on, won’t get recognised by PC at all, won’t get recognised/updated by Sansa Updater. Tried holding the power button for a minute, charging it with various cables for a long time, no response. Somebody suggested pressing the home button after the power one, that didn’t work either.  Any other suggestions?

I do like the device, would love it if I could keep it.

My Sansa Clip just died today too. Listened to a book during run, came home and then “GOODBYE” was stuck on the screen. Computer didn’t recognize it either. It is totally dead. Nothing works not even pushing on or the house. I know it’s charged–did it yesterday and only had it running for 1.5 hours today. Love my Clip but have only had for two years I think.

Wait a couple days for the battery to die and then try to start it.

On the Sansa, the power switch or button is the hard wired master control. This control can force a reset of the device if held depressed or slid to the ON position for 30 continuous seconds, depending upon which model you have.

Remember, the little guy is running a program continuously, whether on or off. When “off”, the device is merely sleeping. If the device freezes for some reason, it ignores command inputs.  Try resetting the device.

If the battery connection has failed, or the battery is totally dead, try using a USB power adaptor to provide DC power for the device. If it dies immediately upon disconnect, the battery or internal connections may be the culprit.

Bob  :dizzy_face:

I didn’t know this. And so the player continues to draw power even though switched off (and it has said Goodbye)? And so off is not off?

I never gave the device’s low power mode a second thought until I had a defective ULP (ultra low power) oscillator begin to drift on my e280.  When you turn the device off, its power demands are miniscule, like a wristwatch (almost).

The Clip is idling, awaiting a command to wake up again. If the program halts, this is why the device appears to play possum, not even responding when plugged in. The soft reset (holding the power button 30 seconds) commands the processor to try a restart.

Other possibilities are if the device recognizes that there is power on the USB connection,  or if the internal battery voltage drops to the minimum threshold level: these can wake up the processor as well in some cases.

Bob  :stuck_out_tongue:

Ah–I guess that’s how its clock stay up-to-date (time) . . . .