Clip+ will not turn on and wont be recognized by computer as Sansa dont want to have buy a new one

I have a had this clip for about a year and never had any problems with it but recently it seems pretty much dead to me.

A week ago I left it plugged into my usb to charge and when I came to use it the problems started.

First It would not turn on and I looked up ways to solve this and tried the reset trick holding the power button. After I got it to turn on it would freeze at the flower icon. I began trying resets and suggestions on these forums but then I got the error message that the memory was full and I need to remove 90 mb of memory. I know its not full but at this time I couldnt get it to connect to my pc to try to delete any files. After trying for a few days and a bunch of resets I finally got my computer to recognize it but It wouldn’t let me do anything until I formatted it. So I did this hoping it would wipe the memory and I could just put all new songs on it.

Now to my current problem. The clip will not power on no matter what reset trick I try now. I have tried all of the ones I could find. holding power button for 30 sec, holding the middle button, holding power and then home button. Nothing has worked and my computer can recognize it when I plug it in but only as a removable disk.

 I would like to try to fix this and not have to buy a new one and im pretty sure its over the warranty because its older then a year. Any suggestions would be greatly appreciated. I can’t tolerate running without an mp3 player to listen to music so I would like to fix this as quickly as possible

Hopefully a lead to the battery did not come undone.  

What you might try is to leave the player connected to a power source for a day and see if that trickle charges the battery so that you can start up again.  

I’m having this exact same problem.  It ■■■■■, and I’ve only had the device a few months.

The last time it was working (a week ago), I unplugged it from the computer and while refreshing media content, it froze, and then screen went black.  I was able to successfully soft-reset the device once, but while loading back up, it again froze during the flower logo.  Now the screen will not turn on, no matter the button combo.

I’ve tried plugging it in via wall-charger and USB charger in every port on 3 separate computers, and I’ve tried leaving it plugged in for a few days.  It is also only recognized as a removable disk, and Windows formatting is unsuccessful, not matter what options I select.  If I try to soft reset, windows makes the notification noise that something has been connected, but that is all I get.

Is it time to break this thing apart and try to fiddle with the wires?  Any guidance on this?

Such a shame because I was previously very happy with the device.  Please help SanDisk!

okiedokie wrote:

I’m having this exact same problem.  It ■■■■■, and I’ve only had the device a few months.


Believe it or not, several people have reported that ignoring it for a while (a week, a couple weeks, a month, etc.) and then going back to it results in a completely re-incarnated player. Why? No one knows, but it’s been known to work in some cases.

Of course if you don’t want to wait that long, you can always call SanDsik Tech Support. If it’s only a few months old as you say (and it was bought as new, not re-furbed) it would still be under the 1 year replacement warranty. If you live in the States, Sandisk generally picks up the tab for sending the defective one back to them too. Pretty awesome service! :wink: