Clip+ won't turn on and PC won't recognize it...


I have owned a sansa clip+ for about 9 months now and it has been working perfectly.

Yesterday, though, after charging it on a USB port on my PC (win 7), I removed the USB cable and tried to turn it off, but It freezed at the sansa logo screen.

I reseted it (by holding the on/off button for 30 sec), but then could not turn it on again. I then pluged it back to the USB port, but my PC would not recognize it and would allways shows an error “code 43”. I have tried all my USB ports, different cables, on a different machine, but somehow it still refuses to work.

I left it on a USB adapter over night and somehow it started working long enough for the PC to demand a full format, which I did.

The player menu somehow became available then, so I reseted to the factory standard and then proceded to apply a firmware upgrade 01.02.15 with the Sansa Upgrader, but that failed numerous times. I tried to apply the update manualy, but somehow copying any files to the drive was not possible. After that, nothing works.

My PC can’t recognize it, or when it does, prompts for full format, which It cannot complete. Sometimes I manage to turn it on, but it always freezes at logo. Other times it seems to work (shows the connected screen) if plug it to my PC, but it still won’t recognize it and always shows an error from an unknown device.

It always freezes when I unplug it and the only way to turn it off is to reset it, but then I can’t turn it on again.

Did I miss something? I tried forcing MSC mode, by holding the center button, but that doesn’t do anything.

Did I do something wrong here? It seems strange for it to be so broken after working with no problems before.


Contact Tech Support for a warranty replacement.