Sansa Clip+ 2GB won't start up, not recognized by the PC

On boot, it freezes at the 4 petal logo and doesn’t go past it. The PC doesnt’ recognize it. I tried:
Holding the power button to reset

Connecting to different PCs

Letting it run out of battery

Is it dead?

How long are you holding the power button to reset? Normally, it resets in approx. 20-30 secs. but we’ve heard of extreme cases where it took over a minute.

Had the same problem. On a hunch, I tried a different USB cable. I had been using the one I use for my phone’s backup battery. When I switched to a different cable, it was recognized by the PC. I still have not gotten the problem fixed, the updater program fails, but I’m going to try their manual update procedure:

OK, after changing cables, the computer finally recognized the Clip, oops, mine’s a Clip Zip 4GB, but it may work on yours.

I used the computer to format the device, then after a couple tries, it started, and did not stick on refreshing media.

Used the manual firmware update procedure from my last post. Back in biz, only bummer is I have to reload the music, minor.


1 Like

Excellent advice   Your comment helped me realize only a micro USB data cable will allow Sansa devices to communicate to PC.