Sansa clip frozen to screen 'SanDisk sansa'

My 2GB clip has frozen to the screen ‘Sandisk sansa’. My computer (Windows XP) will not recognize it. When I plug it in my computer shows an unrecognized device. Windows Explorer does not recognize it as an external drive so I can’t use the */f fix error, or add updated firmware. I used Control Panel to install a new external device but got a Code 10 after install; device will probablely not start. My Media Player (v. 11) doesn’t recognize it to re-format the player. I can turn it off by holding the on/off for 20 seconds. Any way to manually reset the player? Help!

You can use the chkdsk function only in MSC mode.

You can force MSC mode by starting with the Clip OFF.  Slide the power switch to the HOLD position (orange showing).

Press and hold the center button down while plugging in to the PC.  The device will connect in MSC mode.

You may then run chkdsk on the device.

Bob  :smileyvery-happy:

I tried to connect in MSC mode as suggested by holding down the center button and plugging into my PC. I got the ‘USB device is not recognized’ message. Clicking on that message suggests either try re-connecting or get another device. I was hoping this Sansa product would work for a while, but guess not. Any other suggestions would be welcomed.

i am currently having similar problems, so i will just add on to this thread. i havent even owned the clip for 24 hours and i’ve had problems with it since i got it. it’s really disappointing after reading so many great reviews on it. ive googled my problems with the player and read the solutions, but the thing is im experiencing multiple problems which prevents me from doing the recommended troubleshoot.

so when i first connected it to my computer, it would not read it. i switched usb ports and it fixed the problem. i updated the firmware and put some songs in it and unplugged it. i couldnt “safely” dismount it using windows, because the icon didnt pop up on my taskbar so i just disconnected it and when i tried to turn it on and it said thati need to free up 30 megabytes for the database. i did a reset and also reconnected it to my computer and disconnected it and it seemed to fix it temporarily. i ended up getting that message 2 more times. so i got to listen to my clip for about 30 minutes, and i fell asleep. i brought to work with me today hoping i could listen to some music, but it kept freezing at the sansa logo. reseting the device with the hold switch didnt help. i tried connecting the device to my computer and now it doesnt recognize it no matter which port i use, or even if i use a different cable. connecting it to my computer does power the device, but it stays frozen on the sansa logo. i tried to connect in MSC mode, and it still does not recognize the device. my coworker says hes been through 3, and the one he has now hasnt had problems for 3 months now. should i exchange it for another clip? i really just dont want to run into problems anymore. if its common, i may just return it and get my money back, which i would hate to do because its very ideal for me at the moment.

any suggestions would be appreciated. thanks.

I am also experiencing the same problem and tried this but I am getting absolutely nothing…zip…nadda…zilch!  I was also unable to do anything with the recommended download for repair so technically, this cute little device is just that…a cute little device! 

Neither my home nor office computer will recognize this little gadget anymore. 

Anything else you can suggest?  I purchased this in December '08! 


update: so my computer crashed and i had to reboot it. i tried reconnecting my clip after i rebooted and it somehow read it, but went straight to “not enough space for music db”. i disconnected and reconnected and it finally made connection with my computer. so i reformatted, and manually installed the firmware because the sansa updater wasn’t working. it seemed to temporarily fix the problem. so i disconnected and turned it on and it stayed frozen on the logo again. wtf? so i reconnect to my computer and disconnect, and turn it on and it loads up the menu. finally! so i check the firmware in the settings menu and it shows 01.01.30. i checked to make sure it was the latest one, even though the stickied thread shows that the latest is 01.01.20. i then tried to add 3 albums, and windows says there isnt enough space on the drive…wow. i checked the capacity of the drive on my computer and it says it has a total of 62 MEGAbytes TOTAL and says ive used up 58.1 megabytes worth of space leaving me 4 megabytes left. so i disconnect it and power it on to see on the settings menu how much space i have, and its true. it says its total capacity is 62 megabytes. so i reconnect it to my computer and (again!) it says “unable to recognize usb” and the player is stuck on the logo again. wow, what a complete nightmare.

update #2: so i reformat the thing again, and manually reinstall the firmware, disconnect, and reconnect and yet again shows that the usb device isnt recognizable. so i disconnect, and power the device and it powered on fine, so i reconnect and it finally made connection with my computer. so i put some songs on the device, and the sansa updater popped up and said that there was an update in firmware. i guess for some reason when i manually reinstalled the firmware the 2nd time, it updated it to 01.01.20 instead of 01.01.30, so i let the sansa updater do its thing and update the firmware. after it finished and was safe to disconnect, the taskbar icon finally popped up, so i was able to “safely” dismount. so i disconnect it and power it on, and now it freezes at the “Sandisk Sansa” logo like the orignal poster is getting. previously, i was freezing only at the sansa “flower” logo thing. so i reconnect and my computer was able to read it, so i disconnect and again ( what a surprise : /) it says “not enough space for music db”. wow, i just cant win. if its not one problem, its another. i can’t believe how buggy this stupid thing is. i mean, if it remained 1 or possibly 2 problems, i wouldve reconsidered exchanging it for a new one…but after so many more problems, im hesitant to test out another clip in fear of frustration and wasting time.

If the clip won’t startup without locking.     plug it into the computer,     open the device,  right click on  Internal memory, select format.   disconnect the clip after its finished.   start it.  if it doesn’t come up without locking up.   plug it back into the computer and reinstall the firmware again…    If it does come up, then go to Settings > Format > yes       formatting it.    also do    Settings > Reset all > yes

If you do get the CLIP to startup,  go to the settings menu and format and reset all,   and to be safe, reinstall the firmware.     01.01.30 is the current software  I’m not sure but I think mine comes up as .01.01.30a (Americas version)

Getting a good format.   and making sure the firmware is up to date and installed without errors.   Resetting all.      Is what I would do.   Then after that check see how much space you have.       in MSC mode if you don’t use Rhapsody.   Use MTP if you do use Rhapsody.   

On your computer you may want to update the system bios, chipset drivers and USB device drivers, if you haven’t.  

The Clip is a good little MP3 player,    I think this one just needs to be reformatted and reset.  

If you feel this isn’t going to fix anything,  contact Sansa Support,  they will try to assist you.

Good luck  and I hope you get it working

actually ive reformatted 3 times through my computer, and once through the device itself. again, im having the same problems in random order. i assume its the device itself. it may be defective. im going to best buy right now to exchange it, will give you guys an update. hope i dont run into the same problems, im only going through 1 exchange : /. i really want to enjoy this tiny player, but ive never had so many problems trying to use a simple device.

update #3: i exchanged my first clip for a new one. the new one works completely fine! no problems at all. i am glad i can finally enjoy this player the way its supposed to be enjoyed. the player sounds great. i’m currently using my um2’s with the clip, and i do like the sound, but i feel like the um2’s compliment my sony a728 mp3 player better. however, the clip sounds really good with my hd650 amped. i’m currently waiting for my phonak audeo pfe’s to come in tomorrow. i think they will be a better match for my clip. thanks niko your help. unfortunately neither of those solutions helped me defective player. however, i am now content with my new clip.

Glad to hear you got it exchanged and your enjoying it.    It really is a sweet little mp3 player :slight_smile: