My Clip+ freezed totally, what's the problem? (doesn't connect to PC either)

I opened my 8gb clip+ today and it freezed for couple minutes to the opening logo (the blue sandisk logo). After that it went to the main menu and now i can’t do anything with this, it has been like this for about 3 hours now (and it’s not in the sleep-mode, all lights are on). Only thing that seems to change is the battery icon, but i can’t still shut this down or do anything, it’s still freezed.

What could cause this? Or is my Clip+ just getting old (I’ve been using this for over year now). I have 16gb MiniSDHC card in this, and there’s about 7-8 gb music also, so maybe that caused this? This is the first time something like this has happened for the player though.

I guess i’ll have to wait that the battery runs out and maybe then i can get this connected to my PC (it doesn’t recognize the usb-connection at the moment either).

Reset it. Hold the power button down for 20 seconds. It may power off earlier than this. but continue to hold the button for the full count of 20.

Now see if it will start up normally. If not, do the reset procedure again, but starting re-starting remove the memroy card. There may be something on the card causing the issue.

Let us know how it goes. :smiley:

Reset it. Hold the power button down for 20 seconds. It may power off earlier than this, but continue to hold the button for the full count of 20.

Now see if it will start up normally. If not, do the reset procedure again, but before re-starting remove the memory card. There may be something on the card causing the issue.

Let us know how it goes. :smiley:

Hmm, suddenly this worked for me. Earlier today i pressed the power button for over 20seconds and it didn’t help. Maybe something with the Minisdhc card, i don’t know.

One of the endearing qualities about the Clip is its idiosyncracies–one hour, reset doesn’t work, the next hour, it does; leaving the Clip plugged into the power for a few days suddenly brings it back to life …

my clip+ is saying FAT corrupt connect to pc.

what am i supposed to do??

i tried powering it down and its not working

thanks!!

Can you connect to your computer?  If so, right click on the Click drive, choose Properties, and then from the options, run an error check (and fix) on the Clip (also known as a chkdsk).  Hopefully, that’ll fix matters.

the sandisk screen says connected, but i can find it on my PC