Clip Frozen, Unrecognized, will not format.

I got a clip a few days ago and put some music onto it. When I unplugged it from the computer, it tried to load the music in a loading bar, but the bar froze and did not move for hours. When I forced it to turn on and turned it back on, the clip got stuck on the opening “SanDisk” screen and did not budge. When I plug it in to my XP PC, it does not even see it.

Now, I looked through the forums to try and fix it. I did the “Hold and press middle” thing and my PC now know it -exists-, but sees it as an unrecognized USB and will not appear in Explore or My Computer. Meaning I cannot format this device. I repeat, I tried the fix and it will not allow me to format. My PC says it is unrecognized. My PC tells me it is either missing drivers, or the device is missing something.

I’ve looked through your forums, other forums, and done every fix I can find and it will not allow me to fix this thing.

This is the fourth Sansa product that has been screwed up in some shape or form and I’m beginning to wonder if shoveling out the cash for a Zoon or iPod would be worth it just for the fact the **bleep** things work. These mp3 players and by -FAR- the worst electronic devices I’ve ever spent money on. 

hi dude,  perform a firmware update, then  try to look for the usb configuratons on “usb mode” select  “msc”, that should work for u

As I said, My Computer will not reognize it. Thus, I cannot perform a firmware update of any sort.

the same thing happend to me when i was listening to music        you just have to let its battery die and plug it in nd then in should work        if not plug it in and leave it for a couple days

Back up a little, and try the most basic function first:  hold the power button ON for 20 seconds, to reset the device.  Then try and see if it will power up normally.

The second step would be the OFF, flip to “LOCK” (orange showing), and connect while holding in the center button until it is recognized.

At this point, you should see the device in Windows Explorer.

If it shows up, you can format the device from here, or select format from the device’s settings menu while it is on.

Bob :smiley: