Frozen Clip Zip! Help.

Hello everyone. I received my Sansa Clip Zip (ordered from Amazon) today, so I plugged it into my computer, updated firmware (Sansa Updater), disconnected to finish process (still worked fine) and then reconnected and left it there (for about 4 hours, maybe more). I did not add any music. Now when I disconnected it, it was frozen on whatever the connected screen is. So I reset it by holding down the power button until it shut off. When I turned it back on, the startup logo came on and… nothing happened. Did some google research, tried the 20 second reset after a few tries. Then it wouldn’t turn on, somehow I got it to turn on again. Still nothing. Not recognized when plugged into PC. Also tried holding down the center button and plugging the usb. Nothing. All it does now is play the startup screen twice and the stay on it, then it turns off. Any suggestions?

Are you waiting long enough for the unit to initialize when turning it on? I’ve noticed sometimes the Sansa flower will appear on the screen longer than expected, giving the illusion it has frozen but if I just give it time, it will start up normally.

You could also try pressiing and holding the Home/Menu button a split-second after pressing the power button. This has been known to wake up less-than-cooperative units.

Did you make sure no memory card was inserted when you updated the firmware? And that the battery level was at least 50% (as recommended) before updating?

Sometimes in stubborn cases, a reset of slightly over a minute is required where normally 20 seconds will do.

Thanks for your reply. I am waiting long enough to see what happens, it just turns of after a while. I tried the Home/Menu button, nothing. I never inserted a memory card. I’m sure battery level was over 50% before I updated, and the minute reset did not work. I’m done trying and will be looking to get a replacement. Thank you for your help.

Well, sorry about that but at least Amazon is very good about replacing defective or otherwise un-satisfactory merchandise from what I hear. And quickly too.

Good luck! :smiley:

I have exactly the same problem, the sansa logo pops up twice then freezes on the flower. unfortunatelly , my clipzip is out of warranty. how can I do ?

@v_t wrote:

I have exactly the same problem, the sansa logo pops up twice then freezes on the flower. unfortunatelly , my clipzip is out of warranty. how can I do ?

The Clip Zip hasn’t been out long enough to be out of warranty. It came out in August last year. Sandisk provides a 1 year warranty in the US and 2 years iin the EU.

Unless the Clip Zip is a refurb, in which case it indeed could be out of warranty (as people in the forum have so advised me). But why not telephone SanDisk’s considerate customer service and see if you qualify/can get a replacement? SanDisk even covers the shipping both ways, in the U.S. at least. 1-866-SANDISK (726-3475) in North America. And full support info.:

I live in Vietnam, there is no authorised shop here, just only 3 months warranty. So sad, it seems hopeless.

anyway, tks for help

Going back, did you try a system reset?  (Hold the on button down for 20-30 seconds or more–sometimes, up to a minute is needed.)

The Player to fail to respond, when the Database Update interrupted.

Hold PowerButton  25 Second. Leave Button, and Press Power Button short again. The Flower will Show. Wait the Player erase the database. This Take 2-5 Minutes.!!

Than the Database rebuild will show. Can Take long. 3-10 Minutes with SD-Card. Not interrup this.

Please HELP? My clip zip is frozen and says transfering. what do i do?

Were you transferring files and did you allow time for that?  Did you reset the player (hold the on button down for 20-30 seconds or more)?  

Did you wait until it was finished transferring data and/or use the Safely Remove Hardware icon in the System Tray before yanking the plug? Doesn’t sound like it.

I just had a freeze for the first time. I held the power button for a few minutes, but the flowers kept coming up and freezing. I removed the sd card and all is good. reinstalled sd card and restarted and everything is as it should be.