Sansa Clip+ won't turn on and isn't recognised by a computer.


I have a Sansa Clip+ here, and it won’t do anything. I’ve already tried to softreset it serveral times. Yesterday, I managed finally to turn it on, but as soon as I connected it to my computer the Clip+ froze.

The weird thing is, that it was turned on by pressing the powerbutton and the home button. I was reading for solutions when i had the device in my hand, and I was pressing on the two buttons, when it suddenly turned on.

When the device is connected to a PC, it usually doesn’t do anything. Sometimes, the PC and the device manage to establish the USB connection, and then a windows pops up with that the device has to be formatted, before I can use it. When “Format” is clicked, the computer tries to fomat it and when it’s almost finished, the format fails. I tried to force MSC mode, and it didn’t do anything.

Because I think that the firmware is broken, I installed the Sansa updater. Sadly the updater doesn’t recognise the Clip+.

Hopefully this is clear enough. If there’s other information required, ask me and I will do my best.

Can anyone help me?

Thanks in advance.


EDIT: There seem to be problems with the Clip+ and Windows 8, but that’s NOT the case. I’m using Windows 7 x64.

EDIT2: It seems that everytime I connect it to my computer, and my computer doesn’t recognise it, I get a pop-up balloon with “USB Device not recognized”.

EDIT3: I plugged it in a Windows XP machine, and after a few  tries, I got the message again that it needs to be formatted. I can’t format it, because it’s only 30MB now.

Welcome to the USB device not recognized club:cry: My PC has the same problem.Started a few weeks ago after I had turned off the PC for a few weeks.I have spent countless hours trying to get my Clip to work with Rhapsody:manmad:  I believe the PC motherboard is broken and in turn the USB ports are fried, that means the my pc needs repairs? no way, I have an old XP version that is nearly extinct.I suggest taking your PC to a reliable repair center so they can determine what is wrong.You may end up very frustrated if you try to solve the problem on your own and in the end it turns out you have hardware problems.Under normal circumstances you log into  Rhapsody ( you have a subscription…right?) plug in your Clip via USB and it should be recognized, assuming your clip is authorized by Rhapsody.Hope this helps, my Clip worked for years with my current set up:robotvery-happy:

What has worked for me in the past has been to go under Windows Device Manager and “deauthorize” the Clip drive that is listed there. Then reconnect the player–this forces Windows to try and create a new connection–hopefully this will work for you.