New Sansa Clip + died

Hello,

I have had my Sansa Clip+ for about 1 week, and on the way home from work this evening it just stopped playing. I assumed the battery was dead.  However I have since connected it to my PC as I normally do and it’s copmpletley dead.  None of the buttons do anything. The computer doesn’t recognise it.  

How can it just die like that? Really not impressed.

Has anyone else experienced this?

Many thanks,

Jack

I have tried holding dow the power button for 30 seconds and still nothing.

Solved. I attempted the reset (holding down power button while it was connected to the PC).  I then tried it when it wasn’t connected and now it’s come back to life.

What’s up with that?

It doesn’t always reset when you hold power with the USB connected if I remember correctly.  It usually works better if you unplug it before trying to reboot after a crash. 

yes my new just did the samething  crap out

Give more information if you want people to help you. Did you try holding down the power button for at least 30 seconds? If it won’t turn on, did you try connecting it to the pc? If it won’t connect, did you try connecting it while holding down the center button? If that won’t work, did you try giving it a long charge with an AC usb charger? Sometimes after that it is able to connect. If there is a card in the player, did you try removing it, then try turning it on or connecting? What format are your files? If they are mp3, are your tags ID3 V2.3 ISO8859-1 which the player expects?

Call 1=866-SANDISK if you are in the United States.