Probably been asked a billion times, but my clip no work no mores.

I got my 2G Sansa Clip off of Amazon via Buy.Com. it’s been wroking fine, bragging to ppl about it and carry it everywhere i go. Well today when i got home, i turned it off, but before i did, i noticed that it had a little bit of battery left. No problem, right? I don’t like to overcharge my devices for fear it’ll burn the battery and make it less powerful.

So i heard my from was going to be on the radio tomorrow so i went to set up the station beforehand. then i noticed the battery was completely empty. Without worrying i plugged it into the computer [PC], the USB conenction sound came on, yet the menu didn’t pop up and the Clip screen was black.

As soon as i unplugged it, the clip it self came back on as if the USB was preventing it from coming on. Even with my Blackberry charger. I looked around the site and i saw posts about the power button, the hold/center button, and i tried all of it. Around this time the Clip was completely dead. i tried the hold button/center button again after i left it in the computer for a while. it came on, but much to my chagrinit just told me it was locked before jsut completely shutting off again.

In fact, as i’m typing this the USB Connection sound plays back to back as if i plugged it in and took it out 1 second apart from each other.

Help, much?

Message Edited by TyroneGrizz on 01-06-2010 10:52 PM