2GB Clip not powering on


I added some new music, via Media Monkey, to my Clip last night. Then I left it plugged into my computer overnight to charge up. I grabbed it this morning to take to work. It would not power up at all. I got nothing out of it. I borrowed a charger from someone at work. It turned on and would play some music, but the music I just added the night before would not play, it would just freeze. I left it plugged into the charger for about an hour. As soon as I unplugged it it just turned off. I brought it home and hooked it up to the computer via USB. Same thing. The computer reads it no problem. I can put music on, take music off, but as soon as I remove it it shuts down. I tried resetting it while it was unplugged and while it was plugged in and it’s still not working.

Any help is greatly appreciated

I’m not 100% positive on this, but from your description it sounds like either the battery itself or the connection to it is fried. It works fine every time it gets power from an external source (computer, charger) but shuts down immediately if that source disappears. Anyone else?

It sure sounds like a battery problem; either a fried circuit or a cable coming loose. A replacement might be in order.