recovery

Ok how do I get this thing to work? Ive tried everything for the past 24 hours and the darn thing wont recover for me, just keeps saying on my mp3 “recovering, please wait” how the heck long do I have to wait? Im at my wits end, and I have charged it up so I know thats not the problem, but by all means if someone wants tooffer the advice anyway please feel free to do so, I need help.

thanks lee

What OS are you using? Have you installed the SansaConnect recovery software on your PC? Simply putting your device in recovery mode will not do anything, you need to have the recovery software installed on your machine. Then when you plug your device (which is in recovery mode) into your PC it will automatically launch the Sansa Connect recovery software.

Here is the link to get the recovery tool. Good luck

http://www.sandisk.com/Retail/Default.aspx?CatID=1532

yes I did download the tool for recovery into my pc and it still wont work, I’ve read the instructions very carefully and did everything it said to do but it still doesnt come up on my mp3 or get rid of the mssage it is recovering please wait, would you by any chance know how long this message would stay on my sansa connect for, its been on there since last night and I cannot get it to work properly, any help would be great, thanks lee 

The entire recovery process should take about 15-25 mins.  When you connect your device to your PC, Windows will ask you what application to open.  Choose the Device Recoery application (assuming it is installed on your PC), and the application will pop open.  You must click OK to being the process.  You should see a progress bar in the Application window (not on your device) that shows the progress of the recovery.  The Recovery software will say that it is connecting to SanDisk.  The Sansa Connect will also go through a few differnet screens like “recovering software” with a bright yellow clock image.   

If you are not seeing any of this, try using a different port on your PC, or a different PC altogether.  And if you are still unable to get this working, you should contact SanDisk technical support. 

I hope this helps.

-ML

On mine, in step 5, I had to close out the Windows dialog box and simply double click the DeviceRecoverySetup.

-My Sansa was connected to the PC before I opened devicerecovery.

If you haven’t tried this, I would reboot the PC first, it never hurts.

Music_Legend made a good point, I had my USB connected to the back PC port b/c they are hardwired to the motherboard.

Message Edited by Trac on 12-13-2007 06:20 PM

Ok, heres the deal, I have tried and tried to get this recovery tool to work, I dont know if I am completely stupid or what but I cannot get this thing to work, I have windows XP and I have tried all the advice I have gotten so far, tried different ports, tried downloading different times, have tried rebooting my pc so many times now, nothing works. Today I am going to try this on my daughter’s pc but most likey it wont work either, there is no little box that comes up telling me it is working, it just asks me do you want to run this program now? I click yes and nothing happens. Now if I am the one who is the problem I will take the blame, but I’m beginning to think this sansa connect is a piece of crap, even though before recovery it worked good, should never have made the mistake of using the recovery tool as it will not recover anything, so if anyone knows anything, anything at all about this tool please I beg you to help me, make this thing work. I just dont know what to do before I call tech, and they tell me my sansa is a piece of crap and send it in cause im stupid or something. thanks for reading and or try helping someone who has not a clue…

lee

I don’t think this will help, but it is worth a shot.

Sandisk sent me instructions(email) for the recovery tool, and they were slightly different than the .pdf instructions.

Even though this pertains to getting the Sansa into Recovery Mode, it might make a difference when running the app.

Sandisk:

" Putting your player in Recovery Mode, Downloading Recovery Tool, and Installing and Running the Recovery Tool.

  1. To put player in recovery mode make sure the player is off. With the player off place the hold switch to the ON positions with the Orange color showing"

I tried,tried,tried, and it would not work, the hold switch had to be OFF.

Do the reboot thing again, connect to a good USB port, and try running the Tool with the Hold switch in OFF or ON.

Hope this helps.

Here are the steps for recovery tool.

  1. Install Sansa Connect Recovery Tool on your PC

  2. Power off the Connect completely (hold power button 8-10 seconds)

  3. Hold Right Option button, Volume Up button and power up Connect

  4. Connect displays “Recovery Needed…”

  5. Plug into USB port. Connect displays “Recovering…please wait…” -and- autostart box pops up on PC asking if you want to “Recover Sansa Device using Sansa Device Recovery Program”

  6. Click OK in autostart box to run Device Recovery Program

  7. Sansa Device Recovery program starts and opens welcome screen.

  8. Press OK to continue. Recovery program begins.

  9. Recovery program gets latest Sansa Connect firmware from Sandisk

  10. Recovery program begins ‘copying latest software’ to Connect

  11. Connect display changes to state “Starting Recovery” then “Receiving Software” then “Verifying Software” then “Installing Software”

  12. Recovery program states complete -and- Connect REBOOTS and starts with factory defaults.

It sounds like you get to step 6, but fail to get to step 7. That is the Recovery Program fails to start. If that is correct, then there is a confilct in the PC that is blocking the Recovery Program from running. Try on another PC or start looking at what other running programs,  background applications or driver errors that might be conflicting with the Recovery Tool program.

Message Edited by Greig on 12-17-2007 05:02 PM

I def. agree that I cannot get past step 6 but here is another good question for all you ppl out there who def. know more then me at this point. I had Yahoo music to go unlimited, and cancelled my subscription, do you think that has anything to do with not getting past the recovery process? if it does please write back and tell me to rejoin and I will…thanks in advance

lee

There is no link between the Yahoo music service and the Sansa Connect Recovery Tool functions. They are completely separate.

It sounds like your best bet is to try it on another PC. Something on your PC is blocking the Recovery Tool application from starting.

If you do not have another PC to use, you can try uninstalling and reinstalling the Device Recovery application on your PC.

-ML

The Recovery Tool on your PC has to go online and download new software from SanDisk before it will start the Recovery. Make sure you don’t have a firewall blocking the software on your PC. (I use Zone Alarm and it asked me before the SanDisk software would continue with the Recovery.)

I think you best bet is to try another computer (if you can). The recovery software wouldnt run on my machine either, and kept giving me a error message. I tried it at my uncle’s house on his pc and it worked fine

for me it stops ans says sorry yuot pc must be connected to the internet in order to recover your device software.Please connect to the internet and try again.

I know the feeling… Lets just say break this Connect. P.S. How do break something THAT DOES"T WORK!!!

 After trying to get windows media to recognize it or windows for that mater for 30 minutes.

Yes, your not alone I did it all, downloaded both sansa and media player and USB checks.

 I have a sansa Connect and am running windows vista. Although I have spent to much time trying to get my 130 songs that I downloaded (LimeWire) on my sansa Connect.

The but the old saying, “doing the something over and over is insanity” finally got to me.

 -------------------------------------------------------------------------------------------------------------------------------------

My thanks to irony,   Solution: 1. Hold the power button down for 8 seconds For a full shut down. Yes just tapping it puts it in some kind of sleep mode and windows doesn’t recognize it. But when you restart it and see the Sansa screen and the colored balls load it takes about 4-5 seconds to start up again. Windows see and loads your music and videos.

for me it stops ans says sorry yuot pc must be connected to the internet in order to recover your device software.Please connect to the internet and try again.

Gettin the same exact thing , but just did this to another unit last week so I dont understand…tried using a different pc and still says im not connected to the internet…

Any ideas?

Sorry, your PC must be connected to the internet in order to recovery your device software

Gettin the same exact thing , but just did this to another unit last week so I dont understand…tried using a different pc and still says im not connected to the internet…

 Now its just stuck at the recovery screen on the mp3 player…any ideas?

Any ideas?

Message Edited by afulls04 on 08-05-2009 09:19 PM

Message Edited by afulls04 on 08-05-2009 09:37 PM

The Sansa Connect Recovery Tool definitely needs access to the Internet, in order to download the firmware.  If it’s telling you you’re not connected to the Internet, then either you’re not, or there’s something like a firewall preventing the tool from accessing SanDisk servers.

I am def connected to the internet , and just ran it on another sansa connect last week and worked fine. Have not installed any new software since then and have tried using the recovery tool on 3 different pc’s other than my own so far and says it cannot connect to the internet everytime.