for other SanDisk products forum

http://communities.sandisk.com

check it out!

I also atempted to use the recovery tool. The program could not access the internet. I tried installing the program on 3 different computers. It bricked my Sansa Connect. I also tried the command line code suggested. I could not find all the programs mentioned in the code. I tried that DOS three times. No effect.

 http://forums.sandisk.com/sansa/board/message?board.id=connect&thread.id=685&view=by_date_ascending&page=5

I was left with a Sansa Connect stuck with the Recover Window stuck in the middle of the screen (not even in color.) Very frustrating.

Next, I spent time with John at Sandisk Tech Support. He was very friendly and anxious to help. After I explained to him what had happened, he asked me a few questions and checked with a higher level tech. He said I had an non-functioning unit. There was nothing they could do to help. He actually said it was “bricked”. He mentioned they had been having some trouble with the recovery program. That’s probably why they took it off of their web site. In fact, there doesn’t seem to be any refererence to the “Sansa Connect” on the Sandisk support site anymore.

He told me that I should return the unit to the vendor. He said that if they gave me any trouble, that I was to call back with my reference number and they would stand behind it. My unit was suppose to be new and it came in a white box sealed in a plastic frame. I received the unit two days ago and sent it back to the vendor with a supplied prepaid label yesterday. I don’t think I want to try the recovery program on my replacement.

Any solutions?