I just bought this from a warehouse and after i uploaded some songs, it tells me that recovery is needed and the software is on this site somewhere. HELP!!! 

i did that. it didnt work. it says theres maintenance on the recovery software. and there are no tech support numbers on the site.

can you post a screen shot of the error

I found that I needed to run the recovery tool twice to get it to work.  You’ll probably find it on your computer at:

C:\Program Files\SanDisk\Sansa Connect Device Recovery\ZING.Matterhorn.SansaDeviceRecovery.exe

i dont know how to post the picture, but this is teh message that appears on teh screen:

Sorry, we are unable to recover your Sansa device.

Please call Scandisk at 1866SCANDISK for assistance


When i talked to some tech support people they werent any help and just told me that i should send back my player for a new one. The recovery initiates but wont complete.

Have you tried it again?

yea i have on two other computers… it just won’t work

I mean, did you try it twice on the same computer?

And I mean running the executable installed on your computer, not downloading and running the recovery tool again.

I am having the same issue with mine.  Everything has installed on my computer correctly as far as I can tell.  I run the recovery and it failes after going through the entire process.  Tried it three times so far.

When you say it fails, is there an error message?

I don’t have it with me right now but after the recovery process completes the MP3 pops a message up and say the recovery failed and I need to call the tech service.  I tried it again later last night and still the same results. 

I think that happened to me the first time I tried to update the firmware on a “no WiFi” Connect I bought on eBay.  I then ran the recovery tool again, and it worked.  I’m running Windows XP and couldn’t find a Start Menu entry for the recovery tool, but I found the program itself on my PC at:

C:\Program Files\SanDisk\Sansa Connect Device Recovery\ZING.Matterhorn.SansaDeviceRecovery.exe

Just plug in your Connect, locate the above program in Windows Explorer, and double-click on it.

The recovery program I can run off the PC.  Even when I plug the player into the PC it comes up automatically so I can start the recovery operation.  When the recovery is complete the MP3 player spits up a note that it failed and I need to call the tech people.  Am I doing this right?

Did you hold the buttons on your Sansa correctly in order to get the “Recovery Needed” screen?

The device already displays that recovery screen message.  That very same one.  Basically it starts out at step 5.  Then I follow the steps that the recovery application tells me to do.  Then when the recovery is all said and done the devise goes dark for a few seconds and then the failure message pops up that I mentioned previously.  Should I manuall turn the device off and make it start out a step 1?  I appriciate the help.

Message Edited by heep70 on 05-21-2009 12:00 PM

@heep70 wrote:
Should I manuall turn the device off and make it start out a step 1?



Cool, I will do that and let ya know if it worked.  I will be gone tell Tuesday so i won’t get a chance tell then.  Thanks for your help.  Greg

Ok, I am back.  We tired that instruction sheet step by step and still no luck.  It still says recover failed call tech line.  They are closed time I get home from work.  Now what?  I am open for more suggestions. 

Sorry it didn’t work out for you.

My final suggestion is to call tech support during your lunch break.