My connect won't connect!!!! Please HELP!!!!

I have had my Sansa connct for about 2 years now never with any problems. I had done a recovery once before to update the firmware and that went fine. I recently tried to add new music to my connect and windows popped up asking to check for new updates I cancelled this and tried to continue. But I got the pop up ballon saying there was a problem with new found hardware. I proformed another recovery and recieved the newest updates and my computer still wont recognize my connect. I tried downloading hte driver from the sandisk site but i can’t get it to complete. If anyone knows something else i can try please let me know! I have been trying to fix it for about 3 days now and I am getting nowhere.

When you say you “performed another recovery”, was this with the Sansa Connect Recovery Tool that you’ve had installed for a while?  Or did you download and reinstall the latest Recovery Tool, and then use that one?

yes I used the lastest recovery tool.

Was that the “No WiFi” version?  If not, where did you get it?