My PC won't recognize Clip Sport Plus Player

I bought this product about a year ago, and it worked fine then (same PC/hardware/OS would recognize it and operate as expected).

Now, I don’t know what has changed, but when I attach the USB connection, it won’t recognize it. I’ve tried the troubleshooting here: to no avail (note: I do not even get the “USB Device Not Recognized” pop-up). My computer simply does not seem to be aware that it is connected.

Is there a way to get the necessary drivers through SanDisk?

For reference, I’m running on an HP Pavilion laptop with Windows 10

Thank you…

there are no drivers needed. this device uses the native mass storage class drivers included in windows. 

have you tried a different cable? also tried it on different computers? 

Same here.

Worked fine initially, but now my Windows 7 Pro PC doesn’t see it. It turns on to charge upon plugging it in, but does not show as a connected device. I did try another PC (laptop) and also different cables, but neither of those suggestions work.


Same problem for me (and initially would not even charge). Not being recognised by Win10 (also on an HP Pavilion) but also on my Mac with latest MacOS. Hunted down my old netbook running WinXP - also not recognising.

Then thought let’s find the cable that cable that came with the Clip - easy to recognise as it is a flat cable. SOLVED! Looks like the cable must have a different spec to standard micro USB. 

Never had this problem with old e200 series as the cable was unique.


no it uses a standard micro USB connection. Maybe your other cable is bad. 

Nope.  It doesn’t work on ALL micro usb cables.  I tried 5 before I found the cable that came with in and used it.  Viola!  Success.

Spot on.  The supplied cable works but others do not.  Not sure why.

1 Like

Purchased last year now having the same problem, I have always used the cable that came with it but thanks to the reply that others made I used the cable that came with my ear phones and bingo, THAT WORKED AND THANK YOU !

SOLUTION: remap old drive letter to another drive letter

Go to:

  • Controll panel \ Advanced Computer managment \ Disk managment

  • search drive ‘Clip Sport’

  • right mouse click ‘Change drive leter’

  • change drive to ‘S’

  • open S drive

  • enjoy :slight_smile:

Many cables are not “fully connected”.

For example, cables that come with power banks sometimes only have the 5volt plus and minus connection and not the two data  transfer connections.

They often look identical to a data cable, but only supplyes the charging power, and are probably cheaper to produce.

1 Like

I would corroborate that. Not technically, but what works. I had lost my original San Disk cable, so tried others, but they didn’t work, so I assumed it was the player. I did finally find one that was seen by my PC. Note that other cables that are not seen by the PC still will charge the Clip Sport Plus Player.

I had the same problem when I updated to Windows 10, but solved the problem by using the USB cable that came with the player. I know- sounds unlikely, but when I went back to the other similar cable, it didn’t “see” it. All better!

I only bought the player about two months ago. It has always connected to my iMAC. Just yesterday it stopped being recognized. I use the original cable. Now what?

Thank you…

Maybe try re-starting your iMac and then try reconnecting to your CS+.  

Also, remember to empty the “Trash” after each file management session. 

And, use the Eject command to safely complete all file transfers before disconnecting the USB cable. 

Thank you, that’s just what I did and it worked!  Appreciate the advice.

Thanks - it worked as it should using the original cable.  Like others noted, many cables would charge the unit, but it would not be recognized by my Windows 10 computer. 

With the shelter in place requirement, I have time at home to track down and resolve these pesky problems.  You eliminated a big frustration that was high on the list.  Now on to the fun of doing my taxes.  

Thanks for this discussion. “Use original cable” worked for me too. Interestingly, other (longer & more convenient) cables worked for about 3 weeks, and then they didn’t… Sandisk should put that in their instructions: “Use only OEM cable!”

Would Sandisk be willing to send free cables that work with the device we paid for??

The biggest mistake was buying a Sandisk device. The fact that it does not work without the original cable makes it useless. What a waste of money. Buyer beware, because the company wont warn you in advance of the serious limitations in using a simple cable to upload files.

I just bought a clip sport plus a week ago and it already doesn’t connect to my pc anymore, very disappointing. tried different cables including the original one, to no avail so far.

been ranting about it all day - turns out a friend of mine had the same problem with the same model and claimed warranty in december. he’s still waiting for a replacement and has been repeatedly asking for a refund…