If your player isn't being recognized...

If your player isn’t being recognized…a list of remedies below.

  1. You have sp2. If not get it from here http://www.microsoft.com/downloads/details.aspx?FamilyID=049c9dbe-3b8e-4f30-8245-9e368d3cdb5a&DisplayLang=en

  2. You really do not need media player for your PC to recognize your player.

  3. Check all connections. Any standard mini usb cable should do the trick.

  4. Force player into MSC mode. To do this put the player on hold–> keep the center button pressed–> connect to PC–> release center button only when you get a message sayng ‘new device found’. This should work.

  5. Try shuffling the cable around all the USB ports you have. Senseless, but you just never know.

Trying other USB ports isn’t senseless. Front ports often don’t have as much power as back ports, and if there’s not enough power, the computer won’t be able to identify the Clip.

Ah, nice. Step 4 solved my problem. Thanks for the info.

Grinfin, it might also help you to set your Clip to MSC mode (which the #4 trick forces temporarily), under Settings/USB under the more recent firmwares.

I was ready to smash my player i was so frustrated, your suggestions up here did the impossible.  Im NOT a computer genius Nor am i technologically inclined but this worked, THANK YOU!

I tried everything that everyone has suggested and still cannot get any of the 4 computers that I tried to recognize my brand new clip. 

  1. All of the computers are running XP with at least SP2 (one was running SP3)
  2. All had the latest version of WMP 11 (I even removed and re-installed it on one out of desperation) 
  3. I installed the MTP toolkit on each.
  4. I tried every single USB port on each of the computers (all ports are USB 2.0), using two different USB cables (I confirmed that the cables themselves are fine using another non-Sandisk mp3 player). 
  5. I put the unit in MSC mode (the unit is running v01.01.18A so I tried both ways to get it into MSC mode).
  6. I formatted the thing out of desperation, even though I have not be able to get any files on the unit due to it not being recognized.
  7. The battery indicator is showing half full (I can’t get it past that btw), so a complete drain is not an issue.

I’m pretty much ready to send the thing back, but I’d certainly much rather get the thing to work. I would GREATLY appreciate any and all advice. Thanks!

Did you ever get yours to work? Other than the half charged battery issue and you trying 4 computers, I could have written your post. Was yours a refurbished model?

I just got mine yesterday and I’m pretty frustrated.

This unit was brand new, not refurbished.  It came completely sealed in the original packaging.  I have never gotten it to work with any computer.  The only thing that I can use it for at this point is an FM radio. :cry:

turnerfitz - I called support today and it was determined that I have a defective unit.   I’m just waiting for the RMA at this point.  My suggestion is that you take your unit back to where you bought it and get another one.  Good luck!