any one help me

I purchased the( Sansa clip 2 gb blue) almost a year and since that time  my computer or any other computer cant recognise it …I USE (xp)…Please Help needed essential…i wait

My Dell with XP would only recognize my Clip when the clip was set to MSC mode. That is done on the clip under settings. Hit the ‘Music’ button, then ‘play’, (top of round switch). should say settings on screen. hit center of round switch, then page down to ‘USB mode’.  hit center again. page down to highlight MSC and hit the center again and your done.  That will put the clip in MSC and XP should see it then.


Try MSC mode, as the previous post suggested.  Your Clip should show up as a “removable disk” under My Computer.

MSC mode is fine unless you want to put subscription (DRM) music on the Clip, in which case you’ll need to use MTP mode.  If you’re going to use MTP mode, you should have Windows Media Player version 10 or 11 installed on your computer.

I tried msc mode>>but my pc didnt recognised itnever  my friend  promisedplanet

Try doing a Reset (under the Settings menu).  If that doesn’t work: 

  1. Try a different USB port, preferably one on the back of your PC.

  2. Try a different USB cable.

  3. Try a different computer.

You also can try forcing an MSC mode connection:  Clip off and on hold (so that the orange under the on switch shows), hold the center button down as you connect the Clip to your computer.