Clip not recognized

I see that a couple other people are having the same problem with the clip that I am.

I have Windows XP, Service Pack 2, Windows Media Player 10 & USB 2.0 - just as specified on the packaging for system requirements.

My computer and the other computer I tried at home do not recognize the Clip.

I tried SanDisk support but they were mystified. This is my 2nd try with a new Clip - I returned the first Clip to the store per tech support’s instructions.

Anyone have any suggestions? Thanks for any help.

Try updating to WMP11

try the force MSC mode. turn off the player, put it in the hold position and hold down the center button and plug it in. this will force MSC mode see if it detected now. if not try updating to WMP 11 like sansafix said. if still nothing check device manager and let us know if the device shows up there. this could also be a power issue so if you have a self powered usb hub try that.

Message Edited by drlucky on 10-31-2007 05:32 PM

I tried updating to WM11 with no luck - I will try the other suggestions and report back - many thanks!

I tried the MSC mode - device still not detected. The device wasn’t shown in the device manager, either. I’m going to look into a self-powered hub. I’m disappointed but appreciate all the help!

Did you try the MSC mode on both of your computers?  You said that one computer has WMP 10 and Windows XP SP2 but what about the other one you tried?  Try to access MSC mode this way:

Turn the device off
Turn on the hold switch (push the power switch down until you see red)
Hold the Center button (instead of the rewind button)
Plug the device in while holding the center button.

Hopefully the device will show up with a drive letter next to its name.
Good luck.

It works, hold that center button, force the MSC mode, and it works!

Sweet Dog!


Just bought a clip for my son for Christmas.  Was fooling with it, and it would not recognize.  I followed your tip and cured the problem.  Thanks, I’ll be accessing this forum more often.

Support told me they are working on a fix kit for the Clip.  Cause mine isn’t working either and I just got it.  I’m gonna keep trying a few things.  Its a shame I really like it :frowning:

I just bought my 2GB Clip a week ago. I was running XP Pro with SP2 and WMP 11. I plugged it in, it showed up, and everything worked great.

My PC at work was running the same OS, but had WMP 10. I couldn’t see the player in My Computer when I plugged it in. I tried the “Hold switch while pressing the center select button” to force it into the MSC USB mode. I could see it on the PC. It showed up as Sansa M350, but I couldn’t see the files I loaded from the other PC running the same OS, but with WMP 11.

I downloaded WMP 11 on the PC that had WMP 10, and that fixed the problem. Now the Clip shows up on both PC’s with the “Sansa Clip 2GB” icon in My Computer and all the files show up. To sum it up, WMP 11 worked, WMP 10 didn’t. The package says you only need WMP 10, but that wasn’t the case for me. I also downloaded some security updates for XP at the same time, but I doubt if that solved the Sansa Clip issue. It was probably the new version of WMP.

So far there are a couple things I like about the Clip when comparing to my m200 players. The faster “fast forward” is great for my talk show podcasts that are usually 40 minutes per file. No more holding down the FF button until my finger hurts to get to the point where I stopped listening. I also like the OLED display. It’s brighter, easier to read, and shows more characters per line. My 47 year old eyes can see it better than the backlit LCD display on the m200’s.

This thing is amazing and so tiny. It reminds me of the old original Star Trek series. Mr. Spock used to stick a small card (but much bigger than an SD card) into the computer and look at data and pictures. It was science fiction in 1968, but available for 60 bucks today at Best Buy. 

WMP 11 worked! I, too, was stumped with the ‘not recognized’ issue, but now its working perfectly! Thanks to all for suggesting and confirming!

I had the same problem. Then I tried it on a Windows 2000 machine and it worked perfectly. That made me curious, so I tried it on a Linux machine and that worked, too. So now I use my Linux machine to do all the music transfers. My question is, what the heck were Sandisk engineers testing with? Come on! XP is probably 90% of the machines out there.

Okay, for me: MAJOR PROBLEM.

I’ve gone through every single recognition-problem thread and tried every suggestion, and my comp. just won’t recog. my clip!

Mine is Windows XP SP2 with Windows Media Player 11,

and my clip is v01.01.11.

1st, I do not even understand how the firmware stuff works.

My device doesn’t show up anywhere and doesn’t make the connection sound when I plug it in.

It charges, but won’t work!!!

I’ve been spending almost 5 hours on this issue!


I didn’t understand how the MSC mode work at first, but now I know. Gaarakya1, you may did something wrong. Do the following

  1. Put your Sansa Clip in Hold, which is the button on the left side of Sansa Clip

  2. Hold the Center Button.

  3. This is the MOST important part. Plug in to the USB port on  your computer while HOLDING the center button until your computer regcognize it!!

Try it and see if this works

Yup.  Tried that too.  Nothing!  I upgraded to firmware 17a and this thing crashed - won’t be recognized by the PC but the clip says that it is connected

you ppl w/prob’s :: have you tried from linux?? goggle linux live > download > burn to cd > load > see what happens… just to see where the prob is – clip or winxp.  have you looked at device manager?

I had the same problem and the force MSC mode suggestion worked.  Thanks!

To BroncoX,


Thanks a lot for your suggestion. It is evident that your suggestion was effective…(for other users)

I finally found out what my error is.

No intention of joking, but my problem was that I did not plug in the sansa USB cord deep into the device enough.


To other users:

Make sure your USB plug is plugged all the way in.

Again, thanks BroncoX,


My clip was not recognized by 3 different pc’s all running xp sp2 with media player 11 and all with usb 2.0.
I also tried the “hold center button while plugging in while in hold mode” trick to no avail.
In despiration, I tried a different cable from one of my kids other devices (I do not even know what device but it had identical plug ends) and the problem was solved. A batch of bad cables??? I haven’t decided how to proceed to get a replacement cable: return to store vs. sandisk help?

Bad cable update
In one more attempt to resolve the cable issue, I retried the cable that came with the clip and pressed it in more so it was more deeply seated and voowalla it works. The device is so small and fragile looking I guess I was to timid in inserting the cable. The cable does not have to be seated the whole way to charge but it apparently does to connect. The submitted cable is pretty hard to insert fully compared to the other devices cable that I tried. Hopefully it will get less tight with time.