USB device not recognized

I see that you have a lot of this going on. My friend is having the same problem. I am trying to help.

Mine worked pefectly so told her about it and she bought one too. I tried hers on my computer and it works fine. I tried her cable on my computer and it works fine also. We just got done trying all the suggestions we found on this list with no luck. Her computer has all the correct requirements, I updated her firmware from my computer also and charged the battery. I saw something about holding the button for 20 to 30 seconds. I tried holding the button for a long time until the window with the usb device not recognized came up and then left off. If I keep holding it will that window go away eventually and the device be recognized? 


Do you have windows media player 10 or 11 installed?  If not, you need it for the Clip to be recognized.

Yes. Like I said, She has everything needed. We checked. It works on mine but not on hers and we tried all the tips in the forum. Believe me, we have scoured this place looking for answers. She even called the support # but when you can’t understand the person you are talking to it kind of makes it hard. I’m not sure if we tried holding the button down in msc mode because it was noted that you didn’t need to. We tried so many things that now I start to question what we did do. She has wmp11 but we uninstalled and reinstalled just in case. She has xp and the 2.0 usb ports. I installed the newest firmware for her and charged the battery. If it was mentioned, we tried it.

Good stuff so far.  The burning question now is: is the sansa not recognized in MTP or MSC mode?

Check the device under settings > info.  Does it have the 1.01.20 firmware?  Then go to settings > USB Mode > auto detect.

Plug in the sansa without doing anything else, and listen for a connection “ding”, plus the sansa should show “connected” on its illuminated screen.

You can check for a recognized device on the PC, look at My Computer: it will show up under “other devices” without a drive letter if it is recognized as a portable audio player.  If it shows up with a drive letter under “devices with removable storage”, the sansa connected in MSC mode.

Let us know of your operating system- XP or Vista?

Hope this leads you on the right path-

Bob  :smileyvery-happy: 

I was having the same problem, getting the device error message earlier (I was getting it w/ my digital camera too, so I knew it wasn’t specific to the Sansa)… anyways, I turned my USB printer off and suddenly it was recognized.  Silly right?

Cool stuff.  You can also disable the USB devices, reboot, and Windows will start fresh, with the familiar “USB device found, locating drivers” message.

Glad to hear you’re up and running!

Bob  :smileyvery-happy: 

New food for thought. This is good. She has a digital camera but I don’t think she even hooks it up to the computer. Takes her card somewhere to get the pictures made. I will have to have her see if it is recognized. Will try turning off the printer too.  She has the newest firmware because I put it on for her. She had mentioned hearing a ding the first time she plugged it in but then it wasn’t recognized. I don’t remember hearing a ding when I plugged mine in but that doesn’t mean it didn’t. It does show connected on the screen. XP operating system. When we looked in My Computer, there was a drive letter under devices with removable storage. We didn’t know what it was and couldn’t get it to do anything. She didn’t remember seeing it before. If that is it what do we do.

The drive letter assigned means that the computer has established a connection in MSC (mass storage class) mode.  The default mode for the Clip should be MTP mode (media transfer protocol) when “auto detect” is selected.  If the device cannot be recognized in MTP, it tries next in MSC.  Check the Clip (settings > USB mode > ) for your currrent setting.

MTP mode is used for Windows Media Player and WMA, secure WMA, and transfers of protected music like Rhapsody, Napster, and audiobooks with Overdrive or Audible.

MSC mode is a cool option, and one of the things that makes the sansa unique: it can be used as a flash drive, just like a memory “stick”.  Many users using programs like Media Monkey and others prefer to simply manage the device by dragging and dropping playlists and MP3 files directly to the device.

The problem with the two different modes resides in the minds of Microsoft: they decided that files transferred in one mode will be invisible (hidden) in the other mode.  This is an issue when trying to see what’s on the device from the computer side.  The Clip finds the Music regardless of mode, once you disconnect.

I have found that the quirk can be useful, as I store data on the device occasionally, and using MSC mode separates it from my music and books.

If the Clip is indeed being recognized only in MSC mode, all you probably need to do is uninstall / reinstall Windows Media Player 10 or 11.

Bob  :smileyvery-happy:

When you say uninstall WMP10 or 11 are you completely removing it? When we were uninstalling 11 to reinstall it, what happened was a rollback to 10. Is that what you mean? Then when we opened it the message that there was an update came up so we did that and ended back at 11.

After reinstalling WiMP11, what are your results?  If the installation is happy, and the sansa is set to the default “auto detect” in USB mode settings, it should connect in MTP mode.

Open My computer, and check for the sansa again: it should be recognized in MTP mode, and will be listed under “other” this time, as a portable media player, with no assigned drive letter.  Also, the power management status will be available by right-clicking on the device, and selecting “properties”.

Bob  :smileyvery-happy:

I have been messing around with my Clip because it was not recognized,  I went through all of the threads and trouble shooting guides and nothing.  I was on an unrelated post and tried this tip and it WORKED. It was simple, unplg or shut off your USB printer and blug your clip back in.  Wa la it works.  Kinda strange, but it worked.  I assume that something in the USB drivers is out of whack and I will update those later but for now it works!  Try it.