Sansa Clip not recognized by computer


   I’ve read the postings and know that there is a lot of this going on.  My computer is no longer recognizing my Sansa Clip.  I had an issue with the original USB connection and had to order a new one.  I have that now, but the computer keeps saying the device has malfunctioned and Windows does not recognize it.  I have done the following:

Tried connecting with the device on, the “hold” on, and holding down the middle button

Tried connecting with the device off, the “hold” on, and holding down the middle button

Reformatted the device (now I have no songs on it)

Updated my Windows Media Player to version 11

Downloaded Windows MTP Porting Kit

Downloaded the latest update from Sansa (which I can’t get onto my Clip because the computer won’t recognize it)

I also tried to put the device into MSC mode before connecting, but have no USB option in settings

After I installed the latest update from Sansa and plugged in the device, my computer recognized it for about a minute and started the download, then the “malfunctioned” message popped up again and nothing I can think of will work.  I am very frustrated at this point and desperately need help!  Any suggestions would be awesome!

HEADS UP, new option!

I spent a few days on this in utter frustration, tried everything anyone has suggested. My Sansa Clip 2GB was toggling back and forth between connected and disconnected. Drove me nuts and I ordered a new one and started sending flame to the person on bought this one from on eBay.

Turned out to be: THE USB CABLE!

The USB cable that shipped from Sandisk is bad, flaky connection. Turns out the previous owner ignored it because it’s so short. Used another longer one. I switched to a new cable and the Clip works perfectly!

So if you are getting weird behavior, especially irratic or a change in behavior, swap out the USB cable.

I purchased my sansa clip last week and to be honest so far im regretting it.  Im ready to smash it against the wall and crush it.  First one was a dud.  Second one i managed to get charged but my computer does not recognize it.  I have no way to get music to my player, my computer has no where for me to get it and my USB doenst’ recognize it when i plug it in.  Do they make this stuff for people who ARENT rocket Scientists?  Im  seriously thinking this was a huge mistake and should have went with an Ipod.  please help save this piece of crap from getting returned a second time!

I am having this EXACT same problem. My clip worked fine with any computer until I bought the adapter to have it work through my radio in the car. Yesterday I tried to reformat, and deleted 400 songs off of my player! I’m getting very frustrated! Anyone have any suggestions? I’m desperate!!!

I do not own a clip i have a fuse (dont get a fuse)  but i am getting one for x-mas this year. But i can tell you your problems are most likely because of a

Faluty USB cable.

Wrong mode.

I run linux and winbloze (aka windows) and i can tell you that my version of xp (sp1) doesn’t work with mtp mode. I swich it to MSC mode and voila it works. I just open my mp3 like its a flash drive (in my computer) and it works like a charm.

Look around in settings for something USB realated. 

EDIT: RTFM people. It HAS to be in there.

Message Edited by ZOMG on 11-10-2008 11:05 PM

@zomg wrote:

I run linux and winbloze (aka windows) and i can tell you that my version of xp (sp1) doesn’t work with mtp mode.

I hope you understand that, for any serious use, you must have the latest service pack installed (SP3 for XP). Most programs are written with the latest SP as a requirement.

Having said that, you can make MTP mode work by installing either Window Media Player 10+ or the MTP Porting Kit. Check the Wikipedia article if you want.

What do you mean Serious Use?. I have windows media player 10 installed. My player works fine in MSC. ( None of my music has DRM in it.)  Just fyi the majority of programs i download work with sp1. (like the sansa media converter)

Service packs are free and contain bugfixes, so everyone’s expected to get them. Try asking for help/support anywhere and the first thing you’ll hear is to upgrade to the latest SP. Programs (especially commercial ones; that’s what I meant by “serious use”) are more likely to support older Windows versions than previous SPs. It’s a programmers’ cop-out. :stuck_out_tongue: We can’t afford to keep supporting every Windows version and every language and every SP. That would be madness! :dizzy_face:

Sansa Clip - 1 GB  (Black)

Windows XP SP3 - WMP11

I had the exact same issue that a lot of people are apparently having. I kept hearing the little chime you hear when you plug in a USB device then an error occurs and “install cannot be completed”. 

I went through all the forums I could find and tried all the tricks they suggested.

I tried MSC mode, MTP mode, and Auto Detect mode.  When settings were set to MTP mode I got the install error.  In MSC mode it kept connecting and disconnecting over and over again.

I tried to format I even tried to press the button in the middle while plugging it in with my left leg in the air while facing east.  I talked with Sansa’s tech support that offered the same advice that I found in the forums and got no where.  But at leaset they were friendly and tried to help.

I am running Windows XP SP3 with WMP11 integrated into it so I couldn’t “roll back” to version 10 - I think that this might be part of the issue.  I downloaded the MTP porting tool from microsoft and installed it. That didn’t do anything for me either.

What finally worked - and I hope this helps others because I know how frustrated I was -

  1. Set the player to MSC mode.

  2. While off lock the hold button down.

3. Most importantly - use a different USB cable.  The little black one that came with it failed everytime I plugged it into my computer.  Even after I got it to start working with a different cable I tried using the little black one and it faild again.

I think it may actually be a combination of issues with XP SP3, WMP11 and their black cable.  I’m not exactly sure if the MTP porting tool did anything becuase I only got it to work through MSC mode so I’m guessing it didn’t.