Sansa Clip - very annoying

I’ve been trying to get my clip to work on my computer, in the beginning the computer was finding it but still didnt work properly no matter what I did (put onto MSC, did the whole putting into hold and pressing centre button jazz, nowt worked) I could never actually access the clip.


Now i’ve upgraded media player to version 11, but the computer won’t recognise the clip, as in, nothing happens when I plug it in via USB other than the clip charges. I can’t see the clip anywhere on my computer, the little bing noise that lets you know its connected doesnt happen.


Not sure whats happened, or happening, but I do know that i’m getting bored of listening to only the radio on it for ever.


any suggestions?


(windows XP, windows media 11)



There’s a Microsoft “MTP Porting Kit” that I’ve seen here on the forum.  Try searching for that term.

Then, the simplest thing, the one I always forget: shut down your PC, and reboot. That can cure quite a few ailments. Be sure that your Clip is set (In USB Modes: settings > USB mode > auto detect).

Let us know how it goes!

Bob :smileyvery-happy: 

I had the same problem.  You need to go into Settings on the Sansa Clip and scroll down to

Format.  After you go through the formatting process, Windows Media (XP) will recognize it.


This may indirectly be of some help.

  1. Turn on the Sansa Clip.

  2. Settings > USB Mode > MSC > * be sure to hit the right arrow after arrowing down to MSC.  This changes the setting.

  3. Plug the player into your USB Port

  4. Browse “Windows Explorer” (Start > Run > explorer.exe [OK]) or “My Computer” (On the Desktop or in the Start Menu)

  5. Look for another Drive Letter, ie: H: or J:, something that is beyond your highest drive letter.  If you have 1 hard drive and 1 Optical Drive and that is all, you will have C:, D: and E:.  E: would be your Sansa Clip.

  6. Double click on this new drive letter and you should see that it is acting like a MSC (mass storage class) or USB Thumb-Drive type device.  

  7. click on the Music folder and drag your music in there.

  8. STOP the USB Mass Storage Device within Windows

  9. try playing your MP3s on the player with earphones plugged in, of course!

This is how I load music on my player.  Quick, simple and painless.  Be sure to upgrade your firmware to V01.01.20A before getting to far into all this.  My two Clips had major issues until I did that.  

If your player gets frozen and/or you tried the firmware updater and it froze doing that, search the forum for firmware update and it’ll show you a way to drop the firmware update m300a.bin file onto the root directory of the MP3 Player after you format it from Windows.


you can also open windows media player       click in sync        plug it in         and it should work:wink:

I’ve tried all of the above, for some reason the mp3 player is just not being picked up on ANY computer, i’ve tried on ones that’ve never had it connected before, and it still can’t see it (not in explorer, doesn’t ‘ping’ connected, nothing). I’ve formatted, re-formatted, changed the settings to each of the available options. I just can’t get it to be seen.

It charges fine, so at the moment all I have is a very expensive fm radio.

I’ve tried syncing it in windows media, but it can’t be found.


RAPIDLY losing interest in this stupid device.

Have you tried resetting the Clip? Hold the power slider UP until it powers OFF, then turn it ON again, and try to reconnect.

I’m having the same problems!  I’ve tried everything and it still isn’t working.  Mine isn’t even charging!

Only a thousand times!

Does anyone know how to completely reset the Clip back to its factory settings, maybe that would work?

Johnny, assuming you are doing everything right, your player could very well be defective. It won’t be the first time…  :slight_smile:

There is a : Settings > Reset all > Yes  option…

Yeah i’ve done that type of reseting, now just trying the old let the battery run out and see if that works.

Ok, reading the previous posts, it seems to me the culprit is either the USB cable or the mini-B port of your Sansa Clip has the problem since you tried different computers and also the Sansa Clip is not saying “Connected” at all. If you have an extra USB cable, try to isolate the issue. If still the same thing, return it to the store. Good luck!