HELP....Cannot cnnect Sansa clip to PC..........Been trying for hours

Hello, Hope someone can help with this pleeeeeeease!!

I have a new Sansa Clip 4GB

When I plug the clip into the USB port nothing happens, no error nothing. I’ve tried other devises in the port, they work fine

Conclusion USB port OK

I plug the Clip into my lap top (Dell inspiron running XP SP 2 all good)

Conclusion Clip OK

PC OS is XP SP2

I’ve tried the steps on the Sacndisk Tech support are:

I’ve installed WMP 11

I’ve downloaded the  MTP porting kit

I’ve tried the firmware update…Message is “No updatable Sansa product has been recognised”. “Plug in your device & wait for more instructions”. This is the same as if I don’t plug in the Clip

I’ve followed the step by step insructions to put the thing in MSC mode. Which seems to be a guarenteed solution…nothing!!

Looked in the forum & tried what ever I could find in fact…nothing!!

Nothing…I’m now bald, what little hair I have left is grey & I sit in the corner rocking back & forth

Please please help

go to settings> usb mode> msc

plug it in

that may work. but you cant transfer subscription music and playlist on that mode

Tried that Raggamuffin…no joy

are you getting error code 10 in device manager?

if so try this it has worked for others.

open the command line and type the following 

Net localgroup Administrators localservice /add 

Hi drlucky,

No error message in the device manager, it doesn’t show up anywhere, it’s like the devise doesn’t exist or isn’t plugged in.

But i found that fix on the forum earlier & tried it anyway without success. If I do it again , I get "system error 1378 has occurred

Any more ideas?

No already tried that as well!!

Try a different USB cable.

USB cable is OK it works with this device in my lap top

Check your USB settings as described in that earlier post. If it’s brand new then it should be factory set to Auto-Detect, which defaults to your Windows Media Player 11 (MTP). Try setting the USB settings to MTP and see if your WMP pick it up then. Only other thing right now I can think of is try plugging into different USB port or USB cable. HTH, because it’s really an awesome rugged lil Mp3 player. Good luck!

Thanks Web spin,

Tried on MTP. The PC doesn’t even recognise a devise let alone WMP 11.

Yes tried in the 4 spare USB ports I have on the machine without success

DOOOH

Go to Device’s Settings --> select to format the device, once format is completed, slide the power button up to turn off the device, after device is off, slide the button back to hold position and then press the center button & connect to PC…let’s see if this will work.

…well it was worth a try. Sorry to hear it didn’t solve the problem though. I’m just brainstormin’ what could possibly be the obstacle, and I just gotta ask this…  what type of USB cable are you using? Is it the older USB 1.0 or the faster USB 2.0 ? Alot of  the newer USB devices ( esp. Mp3 players and USB powered external HD’s)  require using the faster USB 2.0 cables. They both look the same physically, but the 2.0 is about 40x faster (YMMV). This happened to me quite a few times when hooking up my  USB powered WD Passport 160GB external HD over at a friends house, the HD’s power light would be powered up as soon as the USB cable is plugged in, but won’t show up in the Windows Explorer, and Install Wizard doesn’t pop up on the screen. Came to find out that my buddy’s USB cable was the slower 1.0. I then went back to my house and grabbed my USB 2.0 cable, and instantly my buddy’s computer recognized the peripheral. HTH Dave, good luck!

“The Sansa clip is the ONLY Mp3 player I can comfortably hear over all the freeway and engine noise when I’m on my motorbike, and small enough to tuck inside my helmet”     (FOR OFF_ROAD USE ONLY blahblahblah! Insert vehicle codes and legal claims here)  :wink:

Hello. I just bought a Sansa Clip and had the exact same problem but it was easy solved. I had not pushed the cable into the mp3player, just enough to make it charge but not to connect to the PC. Push it in a bit more and maybe it will work. Just a thought. :smiley: