Windows does not recognize sansa clip

Hi. I reinstalled XP professional (legit copy) and service pack 3 due to problem I was having with my computer.

Now when I plug in the mp3 player, it says “Found New Hardware” but unable to install driver.

I can’t see sansa mp3 player under My Computer.

What am I missing?  I know mp3 player is good.   Don’t have this issue in other computers.

If you set the player to MSC mode, it should connect fine. No driver needed. If you use MTP more, you may need to download the MTP porting kit from Microsoft.

If you set the player to MSC mode, it should connect fine. No driver needed. If you use MTP mode, you may need to download the MTP porting kit from Microsoft. It probably wasn’t included in the re-installation of Windows.

Or, with MTP mode, you could install the latest version of Windows Media Player, which includes the driver needed for MTP mode.

As a general matter, MSC mode should do everything you need, and works smoothly.  The only thing MSC mode doesn’t do is DRM-protected files–you need MTP mode for that.

@miikerman wrote:

Or, with MTP mode, you could install the latest version of Windows Media Player, which includes the driver needed for MTP mode.

 

Ahh, good thought there Mike. XP originally comes with WMP 9. I believe WMP 10 is the minmimum requirement since it has the MTP driver included.

Yep–at least the manual says Windows Media Player 10 as the minimum (but, why not get the most recent?).

@miikerman wrote:
Yep–at least the manual says Windows Media Player 10 as the minimum (but, why not get the most recent?).

Well, the most recent isn’t compatible with Windows XP.:wink:

@marvin_martian wrote:


@miikerman wrote:
Yep–at least the manual says Windows Media Player 10 as the minimum (but, why not get the most recent?).


Well, the most recent isn’t compatible with Windows XP.:wink:

Well, I guess that could be a reason.   :wink:

WMP 11 hides a lot of the controls, options, etc. WMP 10 is much more straightforward and easy to use. I say this with tongue in cheek as many people have problems with WMP 10 too, but 11 is worse.

I just dislike all WMPs . . . .  WMP and I just don’t jive–when I think it should turn left, it turns right, continuously.  And for the life of me, I’ve never understood why something as simple as a media player gets to be so complicated and hidden with WMP, and why use-ability seems to be in second place.   (An example:  loss of a true mini-mode with the latest WMP.)

This worked for me:

1.  Set the Clip+ to USB setting “Auto Detect” and connect to PC USB port.

2.  Use the PC Device Manager (Go to Control Panel, Then System, Then Hardware) to delete the Sansa Clip+ Device from the PC hardware settings.

3.  Disconnect the Clip+ and reboot the PC.

4.  Reconnect the Clip+ to the USB port and the PC will auto-detect it as “new hardware.”  Now it should work fine in “Auto Detect” USB setting and will “see” ALL the music files.

Great for you, but a big Arrrggh as to the Clip USB Auto-detect mode, which can switch between MTP and MSC modes, potentially making some of your files invisible to your computer some of the time.

Better, in my view, to set and use MSC mode, or MTP mode if you have DRM’ed files, consistently. 

I can’t see sansa mp3 player under My Computer.I’ve tried to plug and uplug it my OS is in good shape.What should I do?

Did you try switching the Clip’s USB mode (to MSC mode, preferably)?

Or try differnt USB ports?

Or try different USB ports?

I have the 8GB Sansa Clip.  It didn’t come with any software.  I plugged it in and it showed Connected on the main screen, but it not showing up in MY COMPUTER.  I can’t download files to it.  I don’t understand previous messages about auto-detect as there doesn’t seem to be anything on my clip that shows a way to set that.  I’m using Windows XP Pro and the recent version of MediaPlayer.  My PC is just not recognizing the MP3 player.  Could it be the player itself is faulty. 

Please help… in layman’s terms.  Thanks!

Yes, the player could be faulty. The cord can also be faulty–you might try a different one (any USB-to-mini-USB cord, like a camera cord, should also work).

And you should reboot the computer. If you’ve got Windows 7…well, my Windows 7 suddenly decided not to recognize my Clip + until I rebooted. No idea why.

But Connected is good.

Turn on the Clip (disconnected from computer). You’ll probably see Music, but whatever you see, use the up or down arrows and click to Settings. Hit the center button. Click down to System Settings and hit the center button. Click down to USB mode and choose MSC. Hit the center button. Now try to connect.

Dude thank you sooo much! This was killing me all morning and it totally worked when I set it to MSC mode. You’re a life saver.