Clip not recognized as USB device, but charging on USB works

Hi all,

recently my Sansa Clip stopped being recognized as an USB device. When I plug it into an USB port the battery symbol indicates charging (and indeed the Clip is charged), but otherwise nothing else happens. The screen does not switch to the “connected” display nor does a new drive shows up on the computer. I have the Clip in MSC mode, but changing it into MTP mode does not work either, no connected screen, no device found on the computer. I checked it on three different computers with three different cables, no luck. On all computers it worked before. Using the menu option to reset the Clip had no effect. The firmware is 01.01.20E.
Another odd thing: when I try to reset the Clip by holding the off-switch for 15 Seconds nothing happens, except that the Clip is normally switched off after about a second.

Any ideas?


 I have had the same thing happen on 3 different clips, a 4gig first, exchanged for another 4 gig, same thing, I thought maybe the problem was a 4gig “thing” so exchanged the 2nd one for a 2 gig. Same thing, I just took the 2 gig back and exchanged for another 2 gig this past Friday. I love the clip, this is very frustrating. It seems to work fine, no problem connecting to my computer (New Computer running Vista with sp1), no problems putting audio books on the clip. I charge with a Razor charger. I unplug, finish a book, plug into the computer to put on another book and it won’t connect. I don’t believe it is the USB port because I also have a Zen+ and tried using the same USB port and cord and it worked fine. The same USB port and cord worked fine when I ran my backup program to an external hard drive. I did try formating it, connecting in a different mode by switching the mode on the clip under settings, tried to connect in MTP by holding down the center button while clip is on hold, tried with a different port. Nothing. Best Buy is going to start locking the doors when I come in so I won’t exchange another one. Help!!!

Edit to add-I do have the latest firmware on the clip, love the bookmarking!

Message Edited by lostknitter on 06-19-2008 07:56 PM

Have you tried formating your device?

No, I didn’t try it. And since connecting it to any computer does not work right now I could not put new music on it, if formatting does not solve the problem. So this is a gamble I don’t like to make…

It just sounds like the data leads/pins are not being completed, since you are getting power and the clip is charging. 

Few things to try.

  • Make sure the usb is inserted fulling in clip and pc (the clip espcially, sometimes it feels like its in but it needs to click fully in sometimes).

  • Make sure you have WMP11 or WMP10 installed (11 is reccomended) 

  • Try different ports on computer

  • try different usb a to b cord

  • try a different computer

Hope something above works, which will reduce what the problem is.

Ok mine does the same a 2 gig.

  1. On PC either usb directly on mobo and through a hub

  2. tried on 2 seperate laptops XP with SP2 and SP3

  3. tried different cables

  4. Reset to factory defaults

  5. reformat heard drive

No good it wants to cahrge but no connecteion and the PC does not even notice I have plugged anything in Even the hub does not indicate this via led. Other portable devices are seen ok such as sticks and MP4 players.

Here is a question: When you plug a thumbdrive in, does the computer recognise it? The same set of drivers the computer uses for a portable memory device would be used for recognising the Clip in MSC mode. I’m presuming you have tried other USB jacks on the computer and go direct rather than through a hub.  Have you tried other mini-A USB cables?

You didn’t specify which operating system you are using. Win95 except version C doesn’t have USB support at all, Win98 does have support but doesn’t have the MSC drivers so those have to be obtained separately (does Sansa offer that?), every other version of Windows should see the Clip plugged in right off but issues with the USB subsystem itself can interfere. Going into the Device Manager and deleting all the root hubs, then rebooting so they can be re-recognised, may resolve the issue but since it is Windows there’s no guarantee on that. :slight_smile: I can’t speak the full spectrum for Macs, but the USB support for plug-in memory devices should be built-in from OS 9.5 forward.  I can’t speak at all on Linux, but others here have implied that the support for plug-in USB devices is there and should pick the device up.

Message Edited by Mushroom on 06-22-2008 03:23 PM

For me I am using XP either SP2 or SP3.

I can see other USB devices and storage devices, and when I first had the unit it worked fine, now it just does not seem to see the pc and the pc does not seem to see the device.

I have tried other ports, and even PC’s nothing.

If the Clip is not recognised by other computers, that may narrow it down to the Clip itself, yes…

same problem here…

I have a laptop with XP SP3 and a PC with XP SP2

On the laptop the clip say cennected and battery is charging.

But I can’t see it in my computer or anywhere else.

When i connect the screen appears where to choose nothing or choose mediaplayer.

On my pc everything works and the popup screen also have the windows explorer choice.

Is it the SP3 maybe???

Message Edited by koden on 06-24-2008 11:41 AM

Koden:  Could be.  You managed to narrow it down with your research that it’s not the Clip, the cable, or the mode the Clip is in – the only difference is the computer (one recognises as MSC device, one does not but it charges).  Either it’s the USB connection or hub, or something in the operating system.  I hate it when that happens!

From Miikerman — "put the Clip in hold and connect the USB cable between the Clip and your computer while pressing the Clip’s center button down (and then upgrade the firmware to the latest and set the USB option that you’ll see)."

It worked…WHooo Hooo!!!  Thank you so much…I was going crazy trying everthing else to no avail.

That’s great to hear!  I think SanDisk could have avoided much hassle originally by shipping the Clip set to MSC mode–but thankfully, they added the option via firmware upgrade.

ok so recently my clip has started doing the same thing the original poster’s did.  Plug it in and it charges but the computer does nothing.  Ive reformated it, erased everything, tried 3 different computers all with diff cables and still nothing.  ive also tried putting the clip in “hold” and pressing the middle button down and still nothing happens! Im at the point of chucking it out the window and buyin an ipod! :frowning: my question to “h2osports” is if you had the same prob how did you upgrade the firmware if your comp cant read it in the first place?  so bottom line is, ive tried everything everyone has posted and nothing seems to work. If anyone has any other options please throw them my way…im desperate…

Having the same issue except under settings (on the mp3 player) I have no option for USB under settings so I can’t change the setting.  I think when I bought this I did have an option but I’m not sure.  Some time a few months back my computer just stopped recognizing the device but would charge it.  It still had the music and would play but I couldn’t add any new music.  I switched cords and computers, nothing.  I reset the device and formated it and nothing.  I also found it odd it didn’t even come up as an unrecognized device in device manager or a corrupted partition in disk manager.  Linux also doesn’t shoot out any info when plugged in.  Usually it will give something even if it’s bad.  For all intensive purposes this device is treated like it doesn’t exist.  Holding down the middle button plugging it in and reinstalling the firmware doesn’t work.  It can’t see the device let alone reinstall the firmware.  I looked to see if I saw a pin bent or anything and nothing.  Any other suggestions?

Sometimes, the USB cable itself may be an issue.  The outer two pins are for DC power, and the center two are the data pins.  The PC can give you feedback regarding the communication status via windows explorer and the device manager.

On the device, we have the “connected” logo, but that’s not a sure indication, as we can only see that the device sees something on the data pins.

Changing to MSC mode is the quickest and easiest way to try and let the PC recognize the Sansa as a memory device, since MTP actually involves a more complex interaction with Windows Media Player.  If your Clip does not have the USB Mode option under “settings”, it has the earliest firmware version 1.01.11.  In this case, it’s wise to update the firmware to the latest version.

You can manually select MSC mode by starting with the device OFF : hold the power switch in the up position momentarily to power down the device (it will say “goodbye” ).  Slide the power switch down to the HOLD / LOCK position (orange bar showing).  Then, hold the center button depressed while plugging the device into the USB port.  Note that this may take several seconds, and the button must remain pressed until the device is recognized.

If the Clip still will not show up, try a different USB port, as not all ports behave quite the same.  Lastly, a simple fix: try a different Mini-USB cable.  I’ve found that the HP camera cables are a nice longer pigtail for the Clip.

Bob  :smileyvery-happy:

Thank you for the advice.  It is the older firmware and I tried your trick with having the device off and then holding the power on button until it comes and and then shuts down with goodbye.  I then switched it to lock mode.  I held the center button in and plugged it into the USB slot.  I continued to hold the center button in for 20 or 30 seconds.  I then used a different USB cable and plugged it into a different USB slot and repeated the procedure.  Nothing.  

Sounds like something has gone awry on the USB comm end.  Try connecting your device on another computer to confirm the situation.

If she’s dead, call 1-866-SANDISK for a new device.

Bob  :cry:

Thing is 6 months old and I got it as a christmas present (I don’t have a receipt and I didn’t register it).  Will this be a problem with a return.

No–the Clip is under a year old since introduction, and that’s the warranty period (in the U.S., at least).