Sansa cliip not recognized by computers.

A little help here, please…

I bought my young brother-in-law a clip for Christmas.  One of the ones from Bestbuy if that matters.  Black, 2GB.  Anyway he said he couldn’tget it to work, so I offer to take it home and figure it out for him.  Finally saw him and picked it up this afternoon, and that was the start of a frustrating evening.

I have 2 PCs that I’ve tried it with.  Both are running xp with SP2.  One is Media Center 2005, and right now I’m on Tablet Edition.   On the MC system if I plug it in while off the  clip starts up and says  it’s connected, but the computer doesn’t so much as twitch.  It doesn’t even flash a new hardware message.  No reaction at all.  In I plug it in on or sleeping the battery icon makes charging animations, but the clip stays in play mode with all menu items functional.  On the tablet I can’t get it to go to connection mode at all, only active but charging.  Both PCs have the latest version of Media Player, and I installed the Rhapsody software to the Media Center. 

I have tried removing all other USB devices.  I have tried the hold/center button thing a dozen times on each computer, holding buttons for various amounts of time, starting on, starting off, starting asleep, etc.  I have formatted and reset and reformatted and rereset.  I downloaded the new firmware, but since the computers never read the device at all it can’t find the thing to update.  I have rebooted.  I have rebooted with the clip attached while restarting.  I have gone through this forum and tried everything I’ve seen.  What else can I do?

I can try returning it, but being left with a young relative for a month the box is dishevaled, the plastic window missing, and some of the paperwork is probably under his bed, though I do have the receipt.  Currently the device is a gloried radio with a recorder fuction, but hardly all it was meant to be.  I bought the clip at the time after reading the reviews of every player on the market under $100.  Had those reviews mentioned this little problem (which seems pretty prevailent) I might have considered something else, but as it stands I still consider this the best value for my buck.  Assuming I can get it working.

Are you waiting for it to pop up and tell you “Device Connected”?   If it doesn’t you can always go into  My Computer and select it from there at the bottom! 

I’m waiting, checking, refreshing with F5, and a couple of times I’ve gone into Control Panel and told it to search for new hardware.  Nothing.  When I say the computer doesn’t twitch, I mean it.

Time to call Customer Support?

Have you tried changing the “USB mode” on the clip to MSC or MTP instead of AutoDetect?

I had connection problems resembling yours on one computer but got it to work on MSC mode.


If there’s some way to do that besides putting it in hold and holding the center selection button while connecting to the computer, please tell me.  Like I said before, I’ve tried this starting with the unit on, off, and sleeping.  I’d held the button 30 seconds before and after plugging in, I’ve clicked hold off before connecting, after connecting, and just left it on.  Nothing. 

The unit has firmware 01.01.11A which is before MSC mode was a menu item in the settings. 

It is probably at the point of going to customer support.  Are they pretty good about replacing defective units, or should I try my luck with Bestbuy with incomplete packaging?  Does Sandisk ship the new piece with a call tag for the problem piece, or do they expect you to send yours in first on your own dime?

Ouch, sorry. I didn’t realise you had such an old firmware…

Maybe you can try it on more computers at work or what ever?

I have no idea otherwise =(

Can’t do it at work.  They’re very tight on IT security, so even something harmless light this could get me in trouble if the wrong people see me doing it. 

I did dig an old PC out of a closet.  No frills, very little installed software, and with a recent restore.  Nothing that would conflict.  USB 1.1 ports.  SP2, with media player 9.  I knew with the old version of MP it wouldn’t connect in automatic mode, but still no luck in MSC.  And, just like the tablet, the battery acts like it’s charging, but I’m still able to use all functions.  It doesn’t go into connected mode on the device. 

I guess I’ll end up calling support later.  I don’t really feel up to a fight to get it replace this thing right now.  “Well, try this.”  “I have.”  “Try it again.”  “I have.”  “Then do this.”  “Done that.”  Etc.  Plus I’ll be in the city with the best buy where it was purchased tomorrow, so I might as well try the instant swap avenue first.  I really don’t like dealing with people on the phone, nor do I like dealing with returns.  Hence trying everything I can to just resolve it myself.

If anyone from Sandisk is reading this, by the way, I was rather disappointed by the help offered on your own site.  I shouldn’t have to rely on looking through a forum, reading dozens of posts who what appears to be a known, and somewhat common issue with early fireware not connecting right.  When I looked at support FAQs on your page every single one of them was about rebates, not actual tech issues,  And even then I found this page through google finding a forum thread directly.  Maybe I’m just blind, and it was well past midniight so I was a bit sleep addled, but it wasn’t obvious to me on your site that this is where to go for help.

It sounds like there is no data connection. It could be the USB cable. Could you try it with a different one? The Clip uses a standard mini-USB cable, lots of devices use one.

If it isn’t the cable, then it is the Clip or its USB port. That could be broken or dirty too, and block the data connection.

Since it is new enough, you may have no trouble exchanging it at the store (despite use), since it is under warranty.

If it shows “connected” on your newer machine…it might have a drive conflict of some sort or what not…have you tried going into the Device Manager and select on Portable Devices and do update drivers from there?  If it’s not successful, try force it into MSC by the trick (HOLD mode, press-n-hold center button) and then once it’s connected, go to device manager and try changing your device’s drive name to see that would help…once it’s recognized on your computer…best bet is to format it and upgrade to latest fw…gl

The PC(s) with connectivity issues may have USB 1.1 ports. Are these older PCs? Very few Pentium IIIs had USB 2.0 and even many P4s and Athlons had USB 1.1.

IIRC the Clip needs USB 2.0 and balks at some older USB 1.1 ports

I believe it’s listed on the retail box as one of the hardware/system requirements

Tablet is USB 2, Old PC out of the cloest is 1.1, Media Center has both and both have been tried. 

Tested the cable on my Lrya media player from RCA and my cell phone.  No problems there.  It is the only cable I have on hand at the moment, though.

It’s going back to Bestbuy.  Bro-in-Law is searching for the rest of the box contents. 

Thanks to everyone who tried to help!

did you ever try updating to wmp 10 or 11?

The Clip needs XP SP2 WMP 10 as minimum requirements… I know msc negates that, but what you can try and do, is update to wmp 10 or 11, if that does not get it working, try manually forcing the msc mode, and rolling the firmware to 18a manually from the link at the top of the forums…

Exact same problem. What do I do?

The problem being, having USB 1.1?

sansa clip not recognized by computers. charging the battery also takes long time . i could not operate at all

Have you tried using USB MSC mode on the player, set under its settings (under USB)?