please help :)

    well… i just bought a 1gb sansa clip today, and i haven’t been able to use it on my computer in either the MTP or MSC mode. I’ve read most of the threads here, but i still can’t do anything.

right now, the clip is connected to the front-panel USB slot and charging. the comp won’t see it, and neither does WMP11. anyway, i’ve tried the lock and hold center button then connect thing, but i’m thinking it still connects in MTP mode. maybe it doesn’t know it’s supposed to connect in MSC mode :stuck_out_tongue: (very old firmware? V01.01.11F do all units initially come with that version?).

anyway, when it’s disconnected from the computer, i can power it on and play the music (well, at least i could, before i tried formating the clip :confused: ). when i try to connect it locked and pressing the center key, it just powers on as usual, and just displays the lock icon. and i get nowhere…

what do i do?? return the clip to the shop?

to add:

i have the blue shine one. I tried it on 3 computers, all running XP SP2. also, i think i read somewhere that someone said that the clip shows a “connecting” message on the display when it’s connected to a computer, but it never happened to me. is it supposed to show that? it’s like the clip recognizes my computer as a battery charger and nothing else, so it doesn’t try and connect. i’m gonna try and get a different usb cable and see where that leaves me.

Please see the numerous posts here about connecting in MSC mode as described above and updating your firmware.  Do a search on MSC using the search box above.

as i already wrote, i tried that. didn’t work. i slide the left switch to hold, press and hold the center button and plug it in the computer… nothing. like i didn’t plug in anything at all.

oh, and i checked, it’s not the cable either.

Did you try resetting the Clip, and trying again?  Power switch up and hold for 15 seconds.  Perhaps that will help.

thanks for trying to help, but it just won’t work…

i’ve tried every usb port on my computer. i’ve tried both winxp and vista… i tried reseting, formating… i think i tried everything there is. just tell me, is it supposed to display “connecting” when it’s connected to the computer? and is there any way to update the firmware if the computer won’t see it?

I don’t want to sound like a broken record, but when you did the hold/button press/connect cable, did you continue to hold in the center button? It can take several seconds for the PC to recognize it. It is a clumsy procedure and difficult to do with only 2 hands…

The first few times I tried this, I came to the conclusion it didn’t work (the MSC mode change) but after doing it right, well, m’golly - it finally worked!

BTW this mode change was present from the very beginning AFAIK, so your FW should also support this method.

Also, I’ve heard that USB 1.1 ports can be dodgy, though you say you tried it on different OSes, I assume that means different machines, and if you’re running Vista, I assume that PC has USB 2.0 ports…

Oh, and yes, it should display “Connected” when connected and there is also an animation on the display showing a Clip and a PC monitor exchanging data.

Message Edited by Click on 01-19-2008 10:28 PM

i think i’m doing the MSC mode power on as it should go. i even tried holding the button for 30 seconds before i plug it in, and 30 seconds after…
I was wondering about the USB 1.1/2.0 thing too. i’m thinking that if the clip is working propperly, then it’s probably the USB that’s giving the trouble. I’m pretty sure that my computer supports USB 2.0, and WIN XP has all the updates installed, so an outdated os is out of the question. (oh, and that vista instalation is on the same computer, but i have 3 more computers running winxp, none worked). the only thing i can think of doing more is to try the player on as manny computers possible, and when it finaly finds the one computer worth of popping it’s “Internal Memory” cherry, i’ll update the firmware.

… but it seems more likely that i’m gonna have to return it by then. *sob*

Do you have a friend who has a working Clip? If so, hook it up to one of your computers, making sure it’s recognized with that combination of computer, operating system, USB port and cable. Then, disconnect your friend’s working Clip and connect your Clip using the same combination of computer, operating system, USB port and cable. Then, if yours fails to be recognized, you have isolated the problem to your Clip. At that point, I’d just return it for another one. However, if your friend’s Clip isn’t recognized, then the problem is likely somewhere in the link between the computer and the Clip. Good luck.

well, I went to the shop and got my sansa clip replaced. i’ve got a new one just like it, and when i connected it to the computer, it’s all working :smileyvery-happy:
so i guess that other one was seriously messed up.

thank you for all your help :wink:

Congratulations, that’s great to hear!  Messed-up electronics are very frustrating …