Help Help Help

I am very frustrated!  I just bought the clip yesterday.  I’ve been trying to get it to show up on my computer.  I’ve tried all of the following…

  • installed the new wmp11

  • tried the thing where you set it to msc, put it in hold, hold down the middle button, etc…

  • re formatted the mp3 player

  • just about anything that’s been listed in the forum I’ve tried.

Anyone have any ideas?

The clip is appearing in MSC mode, but not MTP?  Let your new device charge first in the MSC mode (the battery logo will “roll” until fully charged).

Then disconnect, and turn it on.  On the device, select Settings > Info, and let us know the firmware version that pops up.   The current build is 1.01.20.  If you have the early 1.01.11 version, the Clip will be trying to connect in MTP mode.

Since this mode is our issue, we can try reconnecting first.  If you have a USB Mode selection on the device, select "auto Detect and try again.  Does the Clip say “connected”?

On the PC, go to “My Computer”, and look for the sansa, and see if it is listed under “Devices with removable storage” or “other”.  If it’s in “Devices”, it’s recognized in MSC mode, and not MTP.

The problem will be in the Windows Media Player, as the MTP driver is part of that. 

Let us know what you see!

Bob  :wink:

My device won’t charge.  It says connected when i hook it up to the USB cable, but the battery is not rolling.  The battery is almost dead.  I looked at the firmware version real quick and it says 1.01.18

The clip is set on auto detect.

I don’t have a “devices with removable storage” or “other” when i open “my computer”.

When i hooked it up the first time it showed up as new hardware under “universal seial Bus Controllers/ photosmart 7700 series (which is my printer)” in the device manager.

Try connecting it DIRECTLY to a USB port on your PC, not through the USB hub on the printer.

The printer’s hub is intended for connecting low power devices (flash drives) and I suspect this is your problem. 

Betcha it charges, and works, when connected directly :wink:

That is the whole problem.  It is connected directly to the back of the computer’s USB port. (there are two side by side)  So I don’t know why it would be reading that.

I’ve also tried connecting to the USB ports in the front and no luck.

Any other idea’s?

Have you tried it with the printer turned off or the printer’s USB cable disconnected?  I think I remember reading something about that making a difference for some people a while back.