Sansa Clip Battery is not charging

The battery of my new sansa-clip MP3-player is not charging. When I connect the player by origin-cable to the PC it seems to be loaded for nearly 1 minute, and then it stops, the battery-symbol will not be charged. The player has got the firmware-version 01.01.18F. Should I update it to solve the problem?

Version 1.01.18F should work just fine, at least until we can establish a connection and correct charging.

With the device connected, which mode (USB) have you chosen, MSC or MTP?

The key is that it must say “connected” at the top of the screen, with a strobing battery icon.  The “connected” screen will alternate with the SanDisk logo.

SanDisk requires XP Service Pack 2, and Windows Media Player 10/11 minimum.  This is for the MTP drivers that are part of the WiMP10/11 player.

Go to My Computer and look for the Sansa Clip.  Does it show in this (Windows Explorer) window?  Try a different USB port on the computer, and be sure the connection is clean.

You can try to charge the device first, to make troubleshooting easier.  Unplug the device, then select Settings, then USB Mode, then MSC.  Now plug in again.  Is the Clip recognized?  Watch the display for “connected”, plus the strobing battery symbol.  Once the battery is fully charged, it will switch to solid yellow.

Let us know how it’s going at this point, and if you’re charging.

Bob  :smileyvery-happy:

Message Edited by neutron_bob on 06-03-2008 11:45 PM

I was having a similar problem.  Am charging now because I switched to MSC mode.  However, my sansa is only seen as a removable drive in this mode which means I can’t download my rhapsody to go tunes.  my sansa is not even seen by my computer in mtp or auto detect mode.  What is missing from my computer or my sansa?

i have wmp 11.  Windows XP SP2 have downloaded MTP porting kit.  have been working on this problem for quite some time without relief.  please help.


One cause of this symptom is leaving the player connected when updating to Windows Media Player 11.

The solution is to disconnect the player, rollback to updating to Windows Media Player 10, then updating to Windows Media Player 11 again.

Ok, I rolled back WMP and then reinstalled without clip attached.  Same thing, can’t be seen when plugged in as MTP.  In device manager it is listed as USB 2.0 Device is listed under “other devices” and the USB 2.0 device has a yellow exclamation next to it.  I’ve seen something about this somewhere.

What next?  Thanks! 

Microsoft knows about your problem and wants to help you.  heh heh

Info at this site also gives info on rolling back to WMP 10 and/or making WMP 11 work.

Device not recognized after installing Windows Media Player 11

Some devices that support the Media Transfer Protocol (MTP) might not be recognized in Windows Media Player 11 for Windows XP.

If you encounter this issue, perform the following procedure.

Uninstall the device in Device Manager by performing the steps in Issues with devices after removing Windows Media Player.
Disconnect the portable device from your computer.
Reconnect the device to your computer.
Start Windows Media Player 11 for Windows XP and verify that your device is recognized and displays in the Player.

It’s not the Clip or it’s firmware, it’s MICROSOFT!


I went through the Microsoft directions to roll back WMP, however, I was having the problem before I even did that.  So, I do not believe the problem is due to the roll back.  And my device does not show up in device manager as “portable devices”.  It is listed as “other devices”.

Anyone else?  Should I follow some of the latest message anyway.

Please help.  Thanks.


So, I uninstalled the usb 2.0 device from other devices in device manager. unplugged and replugged device back in per the instructions. It showed up again under “other devices”. And when the wizard went looking for software it said none could be found, so i still have the yellow exclamation.

please help. i so want this to work with rhapsody to go which means i must get this thing recognized as an mtp device.

thank you.

Message Edited by 94506rn on 06-07-2008 06:46 PM

Message Edited by 94506rn on 06-07-2008 06:47 PM

I have a similar problem - my clip is completely out of juice and although when I connect it to the pc it looks exactly as it should, battery on the screen strobing, says it’s connected etc nothing happens and it doesn’t charge. The pc doesn’t recognise it all, not in WMP or My Computer.

When I had non recognition problem with my husband’s clip I disconnected the USB, locked the device and then held down the central button while plugging the USB back in, that reset his device and the pc loaded it as if it were a new device and WMP recognised and all was well. Because mine has no juice, when I switch it on I just get a battery low signal and it won’t let me do the lock and reload trick. I’ve tried resetting WMP, but that doesn’t help. Is it worth buying a USB to mains charger and seeing if I can charge it that way?

The MTP communications issue is most definitely in the Microsoft / Windows Media Player arena, and not the Clip.  This link is a quick fix actually from the Sansa Express forum, but it deals with the Device Manageroption.

Also, try searching with the words “Mode 10” or “MTP Porting Kit”, here in the forum, as these have quite a bit of information that may help.

For your Clip that isn’t charging, manually force an MSC connection by switching the power switch down to “LOCK” (orange), and holding the center button down.  It should begin charging.

If it doesn’t a wall charger will indeed help, or in a pinch, you can plug the USB connector in just about half way, as the two outermost pins are longer, and provide the needed 5 volts.  Sometimes, if the Clip is confused and is trying to establish a connection, it “forgets” about the charging operation.

Bob  :smileyvery-happy:

Message Edited by neutron_bob on 06-09-2008 06:17 AM

Thanks Bob, it seems to be OK again now, I managed to get it to charge using a usb mains charger and then switching the clip off once it was connected. Once it had a charge in it I could do the lock/press down central button/usb routine and now it’s charging happily from my laptop and syncing with WMP.

I have tried everything on these links that I can figure out.  Now I’ve got my device showing up as portable mtp device, but when i right click yellow exclamation to install new driver, wizard doesn’t find software.  the other thing i’ve had happen is code 9 or code 10 error and bottom line i still do not have mtp drivers installed appropriately.  if you’ve seen my other posts i have wmp 11 rolled back and forth appropriately.  i have mtp porting kit installed.

i am trying to remain diligent, but feel like i will never get this thing to work.  PLEASE, can someone get me through this issue?

thank you. 

now even when i connect my clip in mtp mode, it is being seen as a removable drive by my computer.  help!  i just formatted the clip and still the same, only seen as removable storage even in mtp mode.

i am so frustrated.  i have not wanted to go mac/ipod, but i have to say if i can’t get this to work soon, i may have no choice.  i have literally spent hours trying to get this right and nothing is working.  i would much rather use rhapsody than itunes, but if i can’t even get the proper drivers loaded…i don’t know.  i am desparate for this to work.  can someone walk me through this again? 

thanks very much for any time you are able to spend with me on this.