After connecting to PC--> it doesn't recharge and is not detected as an usb-device HELDP!!!

    Hello,
i connected my new Sansa clip to my pc to recharge the battery but it doesn’t do it. All I see in the display ist “connected” and in the first 10 seconds its recharching, but after that the Display shows a full battery.
My PC also doesn’t accept the player correctly as an usb-device.

I have WinXP and SP2 installed and USB 2.0.

Anyone help me!

Thanks

When you unplug the device what does the battery level indicate?

Make sure that you have windows media player 10 or 11. Both WMP 10 and 11 have the MTP drivers inorder for the clip to work.
Also,  without WMP10 or 11 the clip won’t charge properly.

Thanks for the answers!
Ok, I will try and install WMP 11 now, have had number 9…
after unplugging the player, the Battery was completely empty.

Yeah! It worked, after installing WMP 11 it connected and recharched properly :slight_smile:
The only questions are:
How do I change the MTP modus to MSC modus???
and How can I tell the computer that I want to disconnect the device??

I wish there was a way to swtich it from a MTP to MSC device; however, the clip is strictly a MTP device.  You should be able to remove it just like any device from clicking safely remove hardware in the task bar. As long as it’s not writing to the device you can just unplug it. I havent heard any horror storys about doing it that way.

If you update the firmware to the latest you can select MSC mode under Settings>USBMode> MSC

Sansa clip came partially charged from retailer. Worked fine as UMS when plugged into a Mac G5 OSX 10.4.11,and accepted drag and dropped mp3 files into the music folder without problem; only FM radio had no sound (normal sound with music). Clip was exchanged for another unit.

Replacement came uncharged; connected to USB port and Clip showed ‘connected’ with display animation graphic. Device showed up appropriately as USB disk on Mac desktop. After a couple of hours, ‘USB disk’ was dismounted by dragging to the Mac trash (no attempt had been made to drag any music file to the Clip). After disconnecting from computer, Clip was turned on, display lit up with SanDisk logo, but all controls were frozen and unresponsive, unit could only be turned off by holding the off switch for 15 sec. Restarting met with same result. Also did not maintain charge after a couple of restarts. On reconnecting to USB port only splash screen showed, no ‘connection’ or charging indicator.

Though official support is for PC and not Mac, the first unit was able to function as UMS (MSC) device. I am accepting of the fact that I will not be able to utilize the playlist, artists etc. but had hope to use the MSC mode. Had a Creative ZEN-Plus, also PC designated, but worked fine as a UMS.

Any helpful suggestion would be welcome. Would hate to have to give up the Clip for a Shuffle!

Thank you.

Try formatting the device from the mac.

How to reformat with on a Mac. I have a MacBook Pro and just purchased a SanDisk Clip for a present. I am now in Spain and tried to contact your online help staff by phone last night… But she suggested the problem was getting enough power to the device and I needed to purchase a powered USB connection…

Here is the problem… similar to the fellow you responded to earlier… I first connected the Clip to my MacBook Pro as my wifes PC was recharging. When I connected the SanDisk Clip everthing seemed to go rigth… I could see the thing “fire-up” shown the symbol and then indicating a charging battery and also connecting. I could even “see” the device in the computer directory although it appeared that their was no music in the device according to the directory. After about 1 hour of charging, I took the device off of the computer connected the earphones and discovered that I could change the lagnuage and also hear music as well as FM… wonderful! Superb!.. However, I next wanted to load music into the device and I suspected that the device might not be Mac friendly so I hooked up my wifes PC, now fully charged. The PC refused to recognize the device! Then, after a bit of exploring I decided to down load your firmware program. I did that and reconnected the clip… Now it did not function at all! It can only see SanDisk on the front in nice blue letters! Nothing Else! That is when I called long distance to the states! The lady recommended switching the thing off and then putting the hold button on then while holding down the “center select” button reattaching the thing to the computer. This did NOT CHANGE ANYTHING. Still Nothing! At this time she said I must have a power problem?

I can go back to my Mac but I think I need to be led by the hand a bit. It might help to reformat the device but I do not know how to do this. Secondly I notice that on some of your other devices you hold down the return key instead of the center select button while engaging the clip into the computer?

HELP! This is a xmas present for a friend

nanopor