I really need some help

Okay, so i have had my clip for a little over a year now. And i am getting some probelms.

What it was doing before,

It started off that the player would connect with the computer, charg, and transfer music just fine. But when i disconnected the device and tried to turn it on, it simply wouldnt. I just got a black screen. Upon plugging it back up, everything worked (transfering etc. etc.) Unplugging it again, it still would not work.

I tried something i heard someone suggest. “Put it into hold and hold the center button as you plug it up. so the computer can read it. And then format it.”

I did this. But now its ever worse off

It still will not turn on at all.

Now when i plug it up it either

A. Gets stuck at the Sansa screen

B. Charges for a short time then says “disconnected” and freezes till is unplugged.

Now, when i hold the center button and plug it up i get “Windows does not recognize the device. There are no drivers installed for this device.”

So, any help?

-edit-

I tried installing the Automatic updater on my computer.

Now when i plug it in it says “Found MTP Device” then when i check for updates it will say its in the wrong mode and i need to change it. But i cant do so because it will not turn on.

I was prompted to restart my computer by the updater. And i did so. Now i am getting a “Device connected. Sansa clip connected” pop up in the corner. BUT when i connect it it will Freeze. It goes from Connected to “writing” and then freezes.

C’mon, help me?

Message Edited by lulzshock on 09-15-2008 10:20 PM

Message Edited by lulzshock on 09-15-2008 10:26 PM

No one?

I could really use help guys…

Please, someone at least post a number for customer service.

hmmm, What I can suggest for you to do is to reset the player.  Just slide and hold the power switch like for 20-30 seconds.  Then, try to turn on the player again. 

It sounds like your Clip is in MSC mode and the Auto updater only works in MTP mode.  You can try performing an update in MSC mode as outlined in this thread:

http://forums.sandisk.com/sansa/board/message?board.id=clip&thread.id=6720

Hopefully that will get your Clip updated.

As for the general case of the screen going black and not turning on, I’ve had that happen to me when the Clip freezes up while the screen is not active.  I don’t know if that is your case.  When that happens to me I hold up the reset/on switch for 15 seconds.  I never see anything happen, but when I release the switch and push it up again to turn it on, it does turn on.  It’s a reset in the blind but its the first thing I’d try before doing something more drastic like formating it.

You also may want to re-apply the firmware to your Clip–the software could have become corrupted over time. 

Im afraid i cant do any of the above.

There is no way for me to connect my device in order to transfer music. 

Is i plaug it up, the screen freezes, and the computer doesnt pick anything up

if i do the hold the center button thing then it just freezes at the sandisk screen 

Did you try to use the devices format command?

If you can power up stand alone,  you can access it from Settings>Format

He already stated the screen is black. I am too having this issue. My screen is black and I can’t connect it to the computer or else it comes up as an “Unrecognized Device”.

If you can’t get the Clip to power up while not connected to PC then try to reset the Clip (with the Clip disconnected from PC - hold power button up for 30 seconds, release, wait a few seconds, try to power up the Clip again).  Did this work?

Have you tried charging directly without being connected to PC?  I use my cell phone charger (Motorola Q) or an AC USB charger to charge when away from PC.  You can listen (and change settings) while it charges this way as opposed to charging it on a PC.  Does it charge up all the way (the battery indicator goes from ramping up from empty to full and stays solid full)?  If you can charge it this way, what version of the firmware are you running (Settings…System Info…)?

If you’re using a newer firmware (I think anything 01.01.18 or higher), you can change the USB mode in Settings and make sure it’s set to MSC.  (This is the same mode that is forced with the Hold, press Center button, plug in while keeping Center button pressed until computer recognizes Clip trick.  If you release the center button too early before it’s shows connected on PC it might try to connect in MTP mode - perhaps this is what’s happening??)  You don’t need any drivers in MSC mode as this is the same as a thumb/USB drive.  Do all this with it plugged in directly to AC power, no computer involved for now.

Maybe this will get you started.  Hope it helps.

I had heard that you shouldn’t use any other forms of chargers to charge your Clip. 

wall chargers should not be an issue.

@karenlg01 wrote:
I had heard that you shouldn’t use any other forms of chargers to charge your Clip. 

Actually, including as stated in this forum, SanDisk is fine with standard USB wall chargers, and there is/are “Made for Sansa” charger(s) out there, including from well-respected companies.  You can check out Macally, DLO, etc.