Clip + freezes with Flower only

What do I do? It no longer connects with my computer at all.

I should add that I have a Windows XP machine. And the thing worked until I recharged it once!

Have you tried any of the suggestions in the various connection-related threads already here?

Or tried looking through the SanDisk Knowledge database?

Have you tried resetting it? Or changing the USB connection mode?

It very hard to diagnose or make any worthwhile recommendations without duplication of what’s already been tried without knowing more details.

Because nothing shows up at all, I can’t change the mode. It’s a direct USB 2 port, not a hub. I was told by a Sansdisk person to format it, and I did and everything disappeared after that. I have tried connecting it when it is off and pressing the center button, as a Sandisk person suggested, but that does nothing either. I have tried using the firmware loader, but because the “Computer Connected” Picture never shows up, I can’t really do anything. Any help is appreciated.

Don’t know it will help now or not.

You can try to hold the Volume key up and power off button to power it off first.

Then without powering on, connect it with your USB port on the machine. Do check your USB cable is ok and is not faulty as well.

Hopefully it will work, if not return back!!!  

I will give both suggestions a try. I don’t have time this evening (EST zone), but I try it tomorrow evening. Thanks to you both. Any other suggestions will be gratefully accepted.

No, none of these worked at all. I know the USB port is working, because the device used to work. I may have accidentally formatted it in MTP mode. Does that destroy it?

manish_sharma wrote:

Don’t know it will help now or not.

You can try to hold the Volume key up and power off button to power it off first.

Not. All this is going to do is make it blare at full volume when you turn it back on! And potentionally damage your hearing if you’re wearing earphones at the time.

Can you set the Clip+'s USB mode to MSC and then try connecting?

First, try resetting the device via the Soft Reset: press and HOLD the power button down for about 20 seconds, then release.  Try restarting the Sansa Clip+ at this point.

You can then try plugging in to see if the device is recognized.  If you were previously using MTP mode, open a Windows Explorer window by My Computer or press [Windows key] + E.

Plug in and see if the Clip+ shows up as a media device under other.

If it does not show up (does the display light up and show “connected”?)

You can try manually selecting MSC, even if you cannot advance beyond the Sansa “flower” logo.  Remember, it will show up as two drives, SANSA CLIPP, and the Expansion slot, in alphabetical sequence.

Remember, there’s a quirk when working with both USB communications modes: music transferred in MTP will not be visible while in MSC, though the music is there.  You CAN use the chkdsk utility in Windows to check the drive for errors.

Manually selecting MSC Mode:


With the new Clip+ , this procedure is slightly different from the previous version, as we have no mechanical Hold switch.

  • Start with the Clip+ ON or OFF.
  • Press and HOLD the center button, then:
  • Plug in the Clip+.   You can release the button once it begins communicating. It will be in MSC mode.
  • After the communication session, after powering down, the device will revert to the previously selected mode.

Bob  :smileyvery-happy:

Message Edited by neutron_bob on 01-04-2010 07:56 PM