Clip+ would turn on

I used my Clip+ for awhile yesterday afternoon, worked fine.

Went to use it again last night and was totally not doing anything. Tried holding down the pwer button for 15 seconds, etc, nothing. Tried connecting it to my computer, neither the player nor computer recognized each other, player still blank.

Then read about MSC Mode, I still have NO idea what that means, Mass Storage something, but no idea REALLY what it means. But tried that (hold down square center button, then plug in to computer) and that fixed it. Thought I’d share just in case it would help someone else out. I really thought my clip was junk, and I “never did anything to it”!


The clip has three USB settings that can be viewed and changed under the settings item in clip menu. MTP mode uses a standard implemented in later versions of windows for managing external media devices. It requires WMP 10 or later to be installed on winxp. Some people use it and it’s required for managing protected music. Sansa can also use Rhapsody as an alternative to WMP, but I believe WMP 10 or later needs to be installed for full functionality, not sure about this. The mnemonic stands for ‘Media Protocol Transfer’ 

Google claims MSC stands for ‘Media Storage Class’. In this mode the device looks just like an external drive and you can load and manage music by dragging stuff to/from your computer to the clip using windows explorer. Both will support playlist management, bit I suspect that task is a little easier in MTP mode (but not by much).

A third mode, Auto simply selects MTP mode if the connection supports it, else it defaults to MSC. Avoid that one.

If one does not intend to purchase protected titles and that person is not completely technically inept, MSC mode is most straightforward. Just set that mode and leave it there. Check it again if you ever do a firmware update. 

In the end, the USB modes simply are the technology used to connect the Clip to your computer.

MSC mode is the “old reliable” that’s been in place for many years, and that is the most widely-acceptable over computer operating systems.  Hence, if you have an issue connecting, it’s the mode to fall back to, as you saw.

As noted above, however, MTP mode is needed for files protected by digital rights management–MSC cannot handle that.

So for someone not really computer savvy at all, what do you guys think happened to it? I didn’t do anything; I listened for awhile, I shut it off. A few hours later I was going to listen to it in bed for awhile, and it didn’t start, asted dead, like nothing I’d seen it do before. I’ve had the “battery weak, shutting off” message for example, but not like this where it acted totally dead. Then connected to the computer, nothing at all happened, either with the computer or the player. Then I read about holding down the square center button and connecting it, and that fixed it. Oh and as I mentioned I also had tried holding down the power button for 15 seconds, and that did nothing.

ONE thing I did notice; when I did get it to work again, the order the songs were playing in (in random or shuffle mode) were exactly the order they had played in that afternoon. Pretty weird.

Happy it’s working, even though it’s less than a year old.


Unfortunately, there is a certain “gremlin factor” with these players, at times.

One thing to note:  you have a 1 yr. (in the U.S.) warranty for your player.  If the problem recurs, you could contact SanDisk for a replacement (via telephone is best).