Need help- "USB Device Not Recognized"

Ok- just bought my Clip today- will not work with my computer. 

When I plug it in the Clips screen says connected though the battery symbol is yellow 1/2 battery life, but does not blink.

My computer says “USB Device Not recognized. One of the USB devices attached to this computer has malfunctioned, and windows does not recognize it.”

I have unplugged and replugged, rebooted the computer, updated Media Player to 11. Tried the whole Hold/press center button thing.

It plugs in and works on my work computer- charges up and all other stuff, unfortunately my personal music is on my personal laptop, not my work laptop (big trouble if work laptop is used for personal use)

What do I need to do to my personal laptop to get it working? my Clip has version .18A on it already-if that helps.

My computer runs XP, has sp2… Any help would be greatly appreciated!!! Thanks!!!

Not sure but two ideas:

  1. Try different USB ports.

  2. Reformat the Clip.  Yes, I know it works on the other PC, but … reformatting seems to make magic happen sometimes.

At least we have the advantage of knowing that the clip is functioning (it works on the “work” computer).

We have a second advantage: the firmware is of the '18 variety, meaning that the clip will automatically detect MSC ot MTP.

How about taking advantage of that fact!  Stick with your personal laptop first.  Boot it up and see that it’s happy.  Are you running the laptop on its internal battery?  Try running on “shore power”- or the AC adapter, as the USB 5V supply may be the issue.  I see you have XP/SP2 running.  I hope you have upgraded the media player too…11 works great.

Before plugging in the Clip, turn it on, and select Settings- USB Mode- Auto Detect.  Plug in, and see if the clip displays “connected”.  Does the charging icon begin to strobe?  Once the clip is done attempting communication, it goes to having a bit of juice.  Click (on the PC) Start>My Computer.  Do you see the clip?  If it is connected in MTP (media transfer) mode, it will be listed under “Other Devices”, and all you will see is a picture of a little clip.

If the clip is being recognized as a flash drive, in MSC (mass storage) mode, it will show up under “Devices With Removable Storage” (I think- I am primarily using MTP) _and it will show a drive letter with the device name, like G:. _

If the clip is listed, right-click on the icon.  Then select Properties.  The manufacturer, firmware version, and serial number will pop up.  If you are in MTP mode, you will also see the cool “battery life” icon.

If there’s nothing there, force the Clip into MSC mode by first unplugging the device, then selecting Settings>USB Mode>MSC on the clip.  Plug in again. Note!  If this mode is not listed on the clip, you have an earlier version firmware, and will have to try this:

Turn off the Clip.  Slide the power switch to “lock”. The orange band should be visible.  Now, hold the center button in while plugging in to the USB port.  Hold the button in for a bit, giving the PC a moment to recognice the device.  This method forces MSC mode on all versions.

Do you see the clip now?  Well, it’s dangling from the port, but does your laptop see the device?  If you have (Start>My Computer again) a new flash drive with a drive letter, Bob’s Your Uncle!

Are you going to use Windows Media Player, or drag-and-drop mp3 files to your Clip?

For the media player, Rhapsody, etc, you need the MTP mode.  Otherwise, quite a few of us just whip those mp3 files in there directly using MSC.

Let us know how it goes so far.  Once you’re talking with the Clip…we can deal with upgrading the firmware to '20.

Bob  :smileyvery-happy:

Message Edited by neutron_bob on 02-02-2008 06:41 AM

I have this same issue with the USB Device Not Recognized error. My clip has version 1.01.11A of the firmware. It doesn’t have the option of switching to MSC mode in the settings, and forcing it to MSC mode using the hold-the-center-button-down-while-plugging-into-the-USB-port method does not work either. Any other suggestions? Thanks

Additional note on this topic. I did find that the device is recognized when I held down the home button and connected it to my laptop. That’s the good news. The bad news is when I tried to update the firmware, it got to 50% and froze. No choice but to turn the device off and disconnect. I tried this several times and it keeps hanging on the firmware update.

I have more questions than answers -

Explain what you mean by that statement. There is no progress indicator during the firmware update process on the Clip so…50%??

And holding down the HOME button should do nothing different. DO you have a Clip, or something else? Or do you mean the center button? Or??

I see you also reported a formatting failure under Windows (in another thread). Is that resolved? Why were you formatting it?

Ok, so I figured out what was wrong with getting my computer to recognize my Clip. Turns out- and Im not sure how this happened- my USB ports on my personal laptop are not functioning.  I have tried a variety of plug n play items- laptop mouse, flash drives, etc, and nothing is working on my laptop- off to the computer repair shop for us! Hopefully after getting this problem fixed Ill be able to enjoy my Clip.

Thanks for all your help!!

I do in fact have the Sansa Clip.

The Sansa updater does indeed have a progress indicator. First it downloads from the Sansa web site, then it tries to do the update. I would attach a screen shot if I could. In any event, the firmware updater hangs and never finishes. I also get an error saying the format fails each time I try to format the device from my PC.

Also, holding the center button down while plugging the clip in to the USB port has had no effect. The only thing I have found to make the PC recognize the device at all is putting the lock on and holding down the home button while connecting the device. And even that does not work every time. This may be pure coincidence. 4 out of 5 times the device will not be recognized. The 5th time the device will be recognized but I can’t copy any files to it, the updater hangs, and the format command fails.

Bottom line, the device is essentially completely malfunctioning and nothing I have tried has resolved any of its problems. It is one more post on this forum away from being returned to the store.

kevcdecker wrote:

Also, holding the center button down while plugging the clip in to the USB port has had no effect.

You may already know this and didn’t mention it, but … you also need the hold/power switch slid down to the hold position while doing this.

kevcdecker - my apology - please try updating the FW without using the Sansa Updater. You can download the firmware file from here

Then you use the hold switch/center button connection mode to get the Clip to show up as a drive letter, and drop the FW file into it.

When you disconnect the USB cable after that, the FW will be read in - BEFORE the database is checked/refreshed - this is the way I do it and why I questioned the progress indication - anyway this is the most reliable way to get the FW updated and doesn’t rely on some network service/connection that is running all the time on your PC (and used 0.000001% of the time).

Well here’s the latest in this saga. During one of those random times that Windows did actually recognize the device, I tried to update the firmware by just using the Windows drag and drop instead of the Sansa updater. The error I got from Windows said something to the effect of “Delayed write failed” and then the F: drive disappeared from my Windows Explorer. The device still shows “Connected” but Windows no longer recognizes it.

There appears to be no way to get files of any kind from the PC to the device.

…and yet another Windows error. This time when I tried to drag and drop the .bin FW file onto the device in Windows Explorer, I got a message that said “m300a.bin could not be placed on the device.  You do not have permission to create this item.” I tried to drop it onto the Internal Memory part of the directory structure that Windows Explorer displays for the device.

Double click to open the internal memory.  Then drag and drop alongside the other folders.

Same error when I try to drop the .bin file next to the other folders under Internal Memory… “m300a.bin could not be placed on the device. You do not have permission to create this item.”

Also of note - I’m not sure what the folder structure is supposed to be under internal memory, but here’s what I have: One folder called Record. Six files with no name and size of zero bytes (are these supposed to be other folders?). This does not look right to me, and I wonder if it could be the result of failed format (I cannot get the format command from Windows Explorer to complete either).

Unplug the device.

Select Settings>Format>Yes

The try to drag and drop the firmware again.

I performed the format per the previous post, but nothing changed in the folder structure. Also still get the same error trying to update the firmware.:cry:

Can you connect in MSC mode? 

Unplug and Power off the device

Set the lock switch.

Press and hold the center button and connect to USB

Yes it appears I can connect in MSC mode. When I do that, I can see the following folders and files:

Audible (folder)

Music (folder)

Record (folder)





Under the Audible folder is nothing.

Under the Music folder is nothing (This is confusing to me because there are songs on the device and I can play them when the device is disconnected from the PC).

Under the Record folder are FM and VOICE folders, each of which contain nothing.

When I try to drag and drop the FW file, Windows now gives me the following error:

Windows - Delayed Write Failed

Windows was unable to save all the data for the file F: . The data has been lost. This error may be caused by a failure of your computer hardware or network connection. Please try to save this file elsewhere.

It seems like you just cant write to this device.  Maybe try another cable, port or another computer.

If all that fails,  you may have a bad Sansa Clip.

I’ll give it a try. Thanks for your help.