USB Device Not Recognized

Hello. I’m having a bit of a problem with my Sansa Clip. It worked perfectly before, and the problem described below only recently began.

But first, here is my information:

Model: Clip

Capacity: 1gb

OS: Vista Ultimate 32-bit

Firmware Version: Unknown, as the battery is so low I can’t get in to check! The USB interface is providing power when it’s plugged in, but does not seem to be charging the battery.

I get the following message after connecting the Clip to my PC. “USB Device Not Recognized. One of the USB devices attached to this computer has malfunctioned, and Windows does not recognize it. For assistance in solving this problem, click this message.” (But of course, clicking the message only tells you that it’s an unknown device.)

Before anyone says it, no, putting it in the hold position and holding the center button while connecting does not do anything whatsoever.

 If anyone could provide assistance I’d appreciate it. I’ve e-mailed SanDisk tech support as well, but it’s generally the best policy to gather information from multiple sources.

Thanks.

-Ether 

Oh, and sorry for the double post, but I’d also like to note I’ve tried this on both of my PCs and have had the same result.

Hi Ether,

I just got my clip and I get the same problem (OS=XP SP2).

Perhaps you or someone out there can help?

Assaf

I woudl try charging it a bit first using a mini usb charger.  A cell phone charger could work .

Then check your firmware once its got enough juice.

Use the devices Format command.

Update the firmware if you can get a Connection.

You can try to force MSC mode . 

I’ve got an odd experience that I’d like to share. I had this problem, the Clip+ suddenly stopped turning on or being able to connect with my computer. I tried everything recommended by Sandisk and on the message boards. Nothing worked and I filled out a request for a replacement from the website I bought it from.

Then I took the headphones out and it was fine.

Weird.

Definitely never heard this one before.  And definitely weird.  The gremlins at work again.

Strange indeed. I just checked this with both my Clip+ & Clip Zip and they both turn on fine with the headphones connected as well as connecting to my computer.

:confounded:

I found a workaround by cliking the start button, cliking Devices and Printers, right clik on the sansa clip icon if it has a yellow chekmark and clik on “troubleshooting,” if you have that option.  Then clik “apply this fix” and win7 will reload the drivers for the sansa clip and it will charge and work.  This might work with vista also, although probably not with winXP.  If you run XP then you would have to reload the drivers from the device manager by using “update driver” in the properties of the device with the yellow exclaimation mark that is the “usb device not recognized” i.e. the sansaclip.  Inotherwords, with XP, one would open the device manager, right clik on the device with the yellow exclaimation mark (if more than one device is cheked with the yellow mark, make sure you choose the one that is the sansaclip) and choose “update driver” and that will re-load (update) the drivers for the sansa clip, allowing windows to interface with the device.

@sansaclipchip -

I assume you are replying to the original post. Please note the date this was posted was over 5 years ago. It really doensn’t help replying to a message this old. :wink: